Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
16 апреля 2009 · Лирика

7 мая 2009 · Отношения

В чем сила мужчины?.. Каков он, тот мужчина которого можно назвать сильным. Так вот я попробую описать… Сильный мужчина тот, который не поднимет руку на того кто слабее него. Сильный мужчина тот, который способен добиваться своего не физическим или моральным давлением на других, а развивая и двигая вперед самого себя. Сильный мужчина тот, который способен […]


Метки

Метки записей
Игры HP Pavilion dv6000 1с и MySQL Видео портативный аккумулятор антивирус Отзывы Отношения Печатные формы гаджеты office 2007 День жестянщика Драйвер ODBC скачать Бухгалтерия свертка Вопросы Пошаговая свертка автоматизация Оборудование Лирика Мужчина и женщина Взлом 1С Работа Загрузка с компакт - диска Финансы вирус эмулирует нажатие Win Командная строка автозапуск Драйвера расчет ПЗД Фото дравер MySQL скачать сайт Проблемы печать от поставщика Сайты Экономика сертфикаты новости Drivers Файлы 1С jaws Интерент скачать конвертер office 2003-2007 заблокирован Взлом 1 Программы Свертка по партиям Деньги Zver DVD переустановка windows Asus Eee бесплатно Отчет открыть xlsx docx Структура 1С Экстремальные игры мошенничество Программы для 1С СМС оплата Вирусы свертка торговли Делаем LiveCD реестр перенумарация вирус SMS LiveCD Dr.Web Взлом Удаление партий office 2003 Оптимизация Анализ ПДЗ Кино пакетный запуск 1С Ошибки 1С уменьшить размер базы Методика свертки 1С Спорт Скачать 1С сбились номера документов XPE Интренет Добавить новую метку антивирусы восстановить нумерацию Армия связь Интересные места удаляем пароли Oracle Юмор Жизнь сверка базы 1С код защита Windows XP Свертка 1С редактирование DBF контент-провайдер Альпинизм Свертка базы 1С партии удаление документов Установка Windows Вся СМС Интернет Обработки Система свертка в картинках Обзоры взломать пароль перенос документов Спутниковое ТВ Новая форма счет-Фактуры Автомобили просроченная дебиторская задолженность вирус узнать пароль Документы на почту Подключить 1С к MySQL программы для слепых homachi локальная сеть через интернет ZverCD 1с реестр
22 декабря 2010

Учет серийных номеров в торговой конфигурации 1С 7.7

Автор статьи: , 22 декабря 2010 в рубрике , Анализ. Метки: , , . Просмотров: 7 083

Один из клиентов заказал доработку «Торговля и Склад». Клиент занимается розничной продажей автозапчастей и у него встала проблема учета номерных деталей и агрегатов. Суть проблемы в том, что часть товара имеют номера (серийные номера) и если его клиент возвращает товар, то сейчас нельзя достоверно узнать тот ли товар возвращается, который был ему продан или другой экземпляр. Клиент, продвинутый в вопросах 1С, поэтому достаточно точно сформулировал техническое задание по учету серийных номеров товаров. В этой статье я приведу пример как я реализовал данную задачу (по ТЗ клиента). Эта проблема должны бфть актуальна и для фирм, занимающимся продажей компьютерной техники.

doc Учет серийных номеров в торговой конфигурации 1С 7.7

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Как организовать учет серийных номеров в 1С 7.7

1. Создаем оснастку

Создаем справочник «СерийныеНомера«, подчиненный справочнику Номенклатура и содержащий реквизиты:

ДатаПоступления

Поставщик (Контрагент)

ДокПоступления (привязываемся к документы поставки)

Продан (флаг продажи)

ДокПродажи (привязываемся к документы продажи)

Также в справочник Номенклатура добавляю реквизит «Серийный«. Он понадобится нам позднее, для удобной обработки, вводе на основании и других механизмов.

Этот флаг будет выставляться у товаров, которые имеют серийные номара (двигатели, коробки передач и другие номерные агрегаты).

Учет будем создавать на базе регистра, что сильно упростит отчетность. Для этого создаем новый регистр СерийныеНомера.

registr Учет серийных номеров в торговой конфигурации 1С 7.7

Реквизиты нового регистра

Измерениями у регистра:

Фирма — в моем случае фирма одна, но мало ли — добавляем.

Склад — склад, на котором хранится номерной агрегат

Номерклатура — собственно номенклатура

Серийник — совственно серийный номер

Поставщик — поставщик, продавший товар.

Ну и Ресурс будет только один — Количестсво. В принципе во всех движениях он будет равен 1.

2. Отрабатываем поступления

Для этого создаем документ ПоступлениеСерийныхТМЦ

Реквизиты:

ДокОснование

Склад

Контрагент

Реквизиты табличной части:

Номенклатура, СерийныйНомер, ДатИзготовления, Количество

Далее пишем простую обработку проведения и ввод на основании:


Процедура ОбработкаПроведения()
ПроверкаОшибок();
ПроведениеПоРегистрам();
ОбработкаСправочника();
КонецПроцедуры

Где, ПроверкаОшибок — процедура котрая проверяет правильность заполнения реквизитов и еще несколько параметров, так сказать защита от дурака (не буду ее подробно опичывать), ПроцедениеПоРегистрам — собственно проводит документ по регистру:


Процедура ПроведениеПоРегистрам()
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Регистр.СерийныеНомера.Фирма = Фирма;
Регистр.СерийныеНомера.Склад = Склад;
Регистр.СерийныеНомера.Поставщик = Контрагент;
Регистр.СерийныеНомера.Номенклатура = Номенклатура;
Регистр.СерийныеНомера.Серийник = СерийныйНомер;
Регистр.СерийныеНомера.Количество = Количество;
Регистр.СерийныеНомера.ДвижениеПриходВыполнить();
КонецЦикла;
КонецПроцедуры

Ну и ОбработкаСправочника — вносим изменения в элементы справочника СерийныеНомера. Почему-то я решил сделать еще и такую функцию.

Если вносим изменения в элемент справочника, то необходимо также создать процедуру ОбработкаУдаленияПроведения(), которую разместить в модуле документа. Эта процедура будет очищать реквизиты справочника при отмене проведения документа.

Примерно так мы отработали поступления «серийных» товаров.

Займемся теперь реализаций этих товаров.

2. Отрабатываем реализацию

Для начала определяемся какими документами делается реализация товаров. Ну во-первых это конечно же собственно Реализация, еще ЧекККМ. По техническому заданию надо отрабатывать только эти документы. Поэтому, работаю только с ними.

Открываем документ реализация и добавляем реквизит табличной части — СерийныйНомер

sernom Учет серийных номеров в торговой конфигурации 1С 7.7

Добавляем реквизит СерийныйНомер

Далее, я сделал проверку на наличие серийных товаров (у которых стоит флаг «серийный») в реализации, если есть хотя бы один товар, то в табличной части появляется колонка серийный номер, если нет таких товаров, то колонка отсутсвует, чтобы не смущала оператора.


Процедура УправлениеВидимостьюСер()
ВыбратьСтроки();
ВиденСер = 0;
Пока ПолучитьСтроку() = 1 Цикл
Если Номенклатура.Серийный = 1 Тогда
ВиденСер = 1;
КонецЕсли;
КонецЦикла;
Если ВиденСер = 1 Тогда
Форма.СерийныйНомер.Видимость(1);
Иначе
Форма.СерийныйНомер.Видимость(0);
КонецЕсли;
КонецПроцедуры

И в реализации также добавил проведение по регистру серийных номеров:


Процедура ПроведениеПоСерийным()
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
Если СерийныйНомер <> ПолучитьПустоеЗначение("Справочник.СерийныеНомера") Тогда
Если Количество > 1 Тогда
глНеПроводить(Контекст,"Внимание! У серийных товаров количество не может быть более 1 " + СокрЛП(Номенклатура));
КонецЕсли;
Регистр.СерийныеНомера.Фирма = Фирма;
Регистр.СерийныеНомера.Склад = Склад;
Регистр.СерийныеНомера.Поставщик = СерийныйНомер.Поставщик;
Регистр.СерийныеНомера.Номенклатура = Номенклатура;
Регистр.СерийныеНомера.Серийник = СерийныйНомер;
Регистр.СерийныеНомера.Количество = Количество;
Регистр.СерийныеНомера.ДвижениеРасходВыполнить();
КонецЕсли;
КонецЦикла;

Также в обработку проведения добавляем запись в справочник, как и при поступлении.

Примерно тоже самое проделываем и с документом ЧекККМ.

Ну и остается последний штрих — изменить печатную форму накладной и товарного чека, чтобы при наличии серийных товаров в них печатался собственно серийный номер.

Кому надо, могу прислать MD-шник для изучения




К записи "Учет серийных номеров в торговой конфигурации 1С 7.7" 19 комментариев

а как быть, если продается товар в количестве 2 шт и более?

Ответить

Отдельными строками. Для того, чтобы у каждого товара указать серийный номер.
В реализации и чеке стоит жесткий контроль на продажу именно одной единицы серийного товара.

Ответить

Тогда еще нужно контролировать коэффицент единицы измерения

Ответить

Зачем? Он всегда 1. Серийный номер уникален и может быть только у одного изделия.

Ответить

Скинь, пожалуйста, MD-шник. Очень нужно!!!

Ответить

Добрый день! Скиньте пожалуйста мне MD-шник! Заранее большое спасибо!!!

Ответить

Смысл какой? Любой программист перепишет изложенную мысль за пару часов, а просто накатить MD на Ваш — не «гут».
Вышлите лучше свой md-шник — я на него применю «серийники»

Ответить

Здравствуйте. Скиньте, пожалуйста, MD-шник. 

Ответить

Здравствуйте. Та же просьба что и выше, скиньте пожалуйста MDшник

Ответить

Да в МД смысла нет. Код же описан и так…
Если помощь нужна напишите в аську — так посомтрим

Ответить

 скиньте пожалуйста MDшник

Ответить

Добрый день!Куда можно скинуть свой MD чтобы добавить туда серийники?заранее спасибо.

Ответить

admin Reply:

piterpen323@mail.ru

Ответить

Добрый день.А подскажите, а реально выполнить аналогичное дело для 8.2?

Ответить

admin Reply:

По-моему в Управление торговлей есть подобный механизм.

Ответить

А для чего нужен подчиненный справочник серийных номеров?? Если всё хранится в реестре серийных номеров, можно ведь запросом оттуда вытягивать информацию.Вот только вопрос — у меня так же организовано в магазине компьютерной техники — но со временем регистр СерийныхНомеров разрастается, так как появляются на складе «зависшие» и не списанные во время серийники, и очень долго выполняется открытие периода. Подскажите, как можно с этим бороться? 

Ответить

admin Reply:

Подчиненный справочник — это один из вариантов реализации. Вполне можно заносить информацию и в регистр.

Насчет того как убрать зависшие -нужно смотреть конкретно, но в любом случае можно удалить или закрыть документом.

Ответить

Добрый день.Спасибо за столь описание механизма.А как реализовать следующую задачу:Номенклатура одна, а серийников у Родителя множество.Скретч-карты, например.Номенклатура = Скретч-карта номиналом 500 рублей, а вот их сожет быть 100 шт с разными серийными номерами.

Ответить

Добрый день. Можно ли ещё прислать MD-шник для того, чтобы добавить туда серийника?P.S. Конфигурация доработана.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки