Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
20 октября 2010 ·

Столкнулся с проблемой, что при попытке добавить базу 1С предприятие 8.2 на операционной системе Windows 7 появляется ошибка «Не обнаружена установленная версия 1С Предприятия«. Причем ошибка появляется при любых действиях (создании новой базы из шаблона, создание новой чистой базы, добавлении существующей базы 1С). В начале думал, что дело в правах доступа, однако попытки запустить платформу […]


20 июля 2009 · DozoR

Летний вечер перед дозором. Левобережние эжкипажи как обычно собираются перед Вестером. Сегодня как обычно играем 4 мя машинами — 2 левыйх экипажа, 2 — правых. Приподнятое настроение, адреналин начинает играть в крови, общаемся с конкурентами… Ожидание начала игры прошло как то незаметно. Кричит капитан, что пришло задание,  прерывая общение с друзьями из Alter Ego бегу […]


Метки

Метки записей
свертка Структура 1С сертфикаты HP Pavilion dv6000 Отношения Драйвер ODBC скачать Удаление партий перенос документов удаление документов 1с и MySQL Методика свертки 1С Установка Windows редактирование DBF Экономика сверка базы 1С Подключить 1С к MySQL Windows XP Альпинизм Обработки СМС Загрузка с компакт - диска Бухгалтерия Интернет Командная строка просроченная дебиторская задолженность взломать пароль Файлы 1С homachi локальная сеть через интернет бесплатно восстановить нумерацию СМС оплата Свертка по партиям Лирика Кино автозапуск Деньги Интерент контент-провайдер jaws Оборудование уменьшить размер базы Взлом 1 антивирус Отзывы Asus Eee Скачать 1С ZverCD Вопросы код защита свертка в картинках печать от поставщика 1с реестр LiveCD Dr.Web Система Спутниковое ТВ автоматизация office 2003 вирус Ошибки 1С реестр Фото скачать конвертер office 2003-2007 Работа открыть xlsx docx Программы для 1С сайт вирус SMS расчет ПЗД Проблемы сбились номера документов office 2007 Свертка базы 1С Игры Обзоры Интересные места Делаем LiveCD свертка торговли Взлом 1С Сайты новости заблокирован Добавить новую метку Drivers Пошаговая свертка Спорт перенумарация вирус эмулирует нажатие Win Программы Юмор антивирусы Документы на почту XPE Отчет Жизнь Анализ ПДЗ гаджеты Печатные формы Оптимизация мошенничество Драйвера Вся Взлом программы для слепых дравер MySQL скачать удаляем пароли Новая форма счет-Фактуры Финансы связь Видео пакетный запуск 1С узнать пароль День жестянщика Вирусы Интренет Zver DVD портативный аккумулятор партии Армия Свертка 1С Oracle переустановка windows Автомобили Мужчина и женщина Экстремальные игры
24 августа 2010

Отпрявляем почту из 1С

Автор статьи: , 24 августа 2010 в рубрике . Метки: , . Просмотров: 16 580

При написании конфигурации-робота, которая висит в трее и выполняет необходимые обработки по расписанию встала необходимость отслеживать ошибки, возникающие проблемы, записывать в файл и отправлять на почту. Можно конечно использовать для этой цели (отправка почты) средства 1cpp.dll, используя встроенный почтовый клиент, но в этом случае будет запускаться сам почтовый клиент, например outlook express, что не приемлемо, ибо за компом еще сидит оператор. Поэтому я решил использовать внешнюю компоненту DialMail.dll. Компонента Dialmail.dll может многое, в том числе отправлять и принимать почту, работать с FTP — серверами, упаковывать файлы и пр. Меня же интересует только функция отправки писем с вложениями.

e mail Отпрявляем почту из 1С

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Итак, качаем dialmail. Архив содержит саму компоненту dialmail.dll, примеры работы в 1С, файлы для синтаксис-помощника в 1С. В принципе вся необходимая информация содержится в справке к компоненте, поэтому я приведу пример кода для быстрой вставки для конкретного случая — отправка писем из 1С.

Далее по шагам как использовать dialmail для отправки почты.

1. Копируем dialmail.dll в каталог базы данных. ( в принципе можно скопировать в любое место, из которого потом в коде 1С будем подключать). 2. Копируем файл dialmail.als в каталог C:\Program Files\1Cv77.adm\BIN. Это необходимо для помощи с синтаксис — помощнике.

dialmail als Отпрявляем почту из 1С

Методы dialmail в синтаксис-помощнике

Предварительные приготовления завершены, теперь к делу.

3. Заводим почтовый ящик или готовим настройки существующего

Я создал почтовый ящик на mail.ru. Этот бесплатный сервис вполне подходит для наших целей.

Нам понадобятся адрес smtp сервера, логин и пароль от почты.

4. Подключаем компоненту dialmail.dll

Обычно это делается при открытии формы обработки:


Процедура ПриОткрытии()
//.......................
Путь = КаталогИБ() + "DialMail.dll";
Если ЗагрузитьВнешнююКомпоненту(Путь) = 0 Тогда Сообщить("Неудачная попытка загрузить DialMail.dll"); КонецЕсли;
//.........................
КонецПроцедуры;

5. Заполняем реквизиты и оправляем почту.


Процедура ОтправитьПочту()
ОтправкаПочты = СоздатьОбъект("AddIn.SMTP");
ОтправкаПочты.РабочийКаталог=СокрЛП(КаталогИБ());
ОтправкаПочты.УстановитьКодировкуИСпособКодирования(14, 1);
ОтправкаПочты.MakeContentDescriptionTag = 0;
ОтправкаПочты.ПочтоваяПрограмма = "Имя почтовой программы";
//В моем случае ошибки пишутся в отдельный каталог в текстовые файлы, имена которых соответствуют дате.
ВыбФайл = СокрЛП(КаталогОшибок) +"\"+ СокрЛП(ДатаЧисло(ТекущаяДата())) + СокрЛП(ДатаМесяц(ТекущаяДата()))+ СокрЛП(ДатаГод(ТекущаяДата())) + ".txt";
//имя файла - вложения должно быть в кавычках.
ВыбФайл = """" + ВыбФайл + """";
// От кого, Кому, Копии - это адреса почты.
ОтправкаПочты.СоздатьПисьмо(ОтКого,Кому,СокрЛП(СпрПочта.Копии),"Ошибки обмена в " + СокрЛП(Константа.Магазин.Наименование),,"Данное письмо сформировано автоматически. Смотри вложение",СокрЛП(ВыбФайл));
Если ОтправкаПочты.Подключиться("smtp.mail.ru","25",ИмяПользователя,Пароль)=0 тогда
Сообщить("Не смогли подключиться к SMTP-серверу");
КонецЕсли;
Если ОтправкаПочты.ОтправитьВсеПисьма(0,1,0) = -100 Тогда
Сообщить("Успешно отправлено");
КонецЕсли;
КонецПроцедуры

Вот и все. Почта отправляется на ура. Все легко и просто.

Скачать внешнюю компоненту DialMail.dll




К записи "Отпрявляем почту из 1С" 2 комментария

Вопрос — отчего у меня не работает?Задача — автоматическая отправка почты (раз в сутки)Скачал Диамайл 2 7 6. Поставил в папку 1С7 где БИН. Сисадмин сказал что зарегестрировал.ЗагрузитьВнешнююКомпоненту(«C:\Program Files (x86)\1Cv77\BIN\DialMail.dll») прошло норм — сообщение и возврат не было.А вот дальшеПопытка Почта = СоздатьОбъект(«AddIn.SMTP»); — фиг! Вылет по исключению с сообщением Не удалось создать объект из компоненты DialMail.dll  — и занавес!Причем когда я убрал Попытка-Исключение, оставил просто СОздатьОбъект — то следующий оператор    Почта.ПОдключиться (Сервер, параметры…) отработал норм!Но вылетало при попытках присвоить объекту значения реквизитов!ЧТО НЕ ТАК??Самое смешное. Я брал «прототипом» — обработку из пакета ExampleSMTP.ert -которая работала!  (я прогнал майл с рабочего компа на домашний — норм!).Всего лишь копировал процедуры с этого примера в свою обработку.После чего обнаружил что не работает — но перестал работать и Экзампл!! С тем же сообщением. И другие примеры из скачанного пакета — тоже!Я программист 1С, стаж 13 лет. Но с почтой из 1С не работал никогда — вот первый блин выходит комом!   

Ответить

Заработало! В копии базы. Больше ничего не менял! ЧТо за….Предположение: перенося процедуры я, прочтя мануал, решил улучшить и вставил в концеОтправкаПочты.Отключиться(); В копии — убрал.МОгло это «кислород перекрыть»?

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки