Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.

Я уже описывал несколько вариантов вирусов, которые просят отправить SMS с кодом на номера с статьях «Открыл файл, теперь вирус просит отправить SMS«, где пошагово описано как можно удалить вирус из системы, а так же про другую разновидность вируса который просит отправить СМС, где описана более совершенная разновидность подобных вирусов, а так же как убрать […]


2 октября 2010 · Железки, Новости

Долгое время не мог настроить на своем простеньком мобильном  телефоне Sony Ericsson W395 — jimm, при запуске jimm (мобильной аськи) выдается ошибка — Параметры интернет для java можно получить у оператора, при этом jimm даже не делал дальнейших попыток подключиться. А тут решил все таки добить вопрос. Разобрался оказывается все просто.


Метки

Метки записей
XPE бесплатно Zver DVD Asus Eee удаление документов homachi локальная сеть через интернет Спорт Свертка по партиям Игры office 2003 Экономика Вся вирус автозапуск восстановить нумерацию партии Мужчина и женщина просроченная дебиторская задолженность сертфикаты Печатные формы office 2007 Финансы Спутниковое ТВ Драйвера Видео СМС оплата Командная строка Делаем LiveCD Интренет Интерент перенос документов печать от поставщика Анализ ПДЗ Отчет Windows XP Oracle сбились номера документов Отношения Оптимизация Экстремальные игры новости День жестянщика Альпинизм Взлом код защита скачать конвертер office 2003-2007 Установка Windows Проблемы узнать пароль Файлы 1С Работа Скачать 1С программы для слепых Кино портативный аккумулятор реестр jaws LiveCD Dr.Web Удаление партий Бухгалтерия Программы для 1С свертка вирус эмулирует нажатие Win Вирусы Обработки Вопросы сверка базы 1С заблокирован Добавить новую метку Drivers удаляем пароли автоматизация Обзоры Система расчет ПЗД антивирус Лирика антивирусы Загрузка с компакт - диска Взлом 1С сайт Ошибки 1С Свертка базы 1С Пошаговая свертка уменьшить размер базы Деньги Юмор Методика свертки 1С вирус SMS редактирование DBF переустановка windows свертка в картинках перенумарация Интернет Сайты связь Оборудование Свертка 1С мошенничество HP Pavilion dv6000 Новая форма счет-Фактуры Автомобили Программы дравер MySQL скачать Драйвер ODBC скачать Структура 1С Интересные места ZverCD открыть xlsx docx Жизнь Отзывы контент-провайдер пакетный запуск 1С Взлом 1 Подключить 1С к MySQL Документы на почту свертка торговли взломать пароль 1с реестр 1с и MySQL гаджеты Армия СМС Фото
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 064

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки