Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
14 марта 2012 · , Анализ

Другие статьи этой же темы: Часть 2. Справочники. С нового года один клиент попросил доработать по мелочи управление торговлей, редакция 10.3 Вот решил отписать какие доработки в УТ мы с ним делали, для чего они нужны, как работают. Может эта информация кому-то еще понадобится. Итак, немного о клиенте. — Занимается продажей автомобильных запчастей на несколько […]


Вообще то я сижу на корбине уже более года. В принципе все устраивает, чтолько цены слегка дороговаты, а снижать цены на фоне всеобщей «интернатизации» и активного продвижения новых провайдеров Корбина вроде не планирует поэтому я решил попробовать подключится еще к одному провайдеру, но уже на безлимитный тариф. На Корбине у меня тарифный план без ограничения […]


Метки

Метки записей
Взлом Спорт Файлы 1С восстановить нумерацию гаджеты Oracle Новая форма счет-Фактуры Кино Бухгалтерия Asus Eee свертка в картинках удаление документов скачать конвертер office 2003-2007 контент-провайдер свертка бесплатно новости Фото Видео Экономика office 2007 вирус Печатные формы сверка базы 1С LiveCD Dr.Web антивирус ZverCD Интернет Юмор Командная строка открыть xlsx docx переустановка windows Добавить новую метку Альпинизм партии Интренет Лирика просроченная дебиторская задолженность Подключить 1С к MySQL Проблемы Анализ ПДЗ перенумарация заблокирован Вирусы Игры Drivers Свертка 1С Делаем LiveCD Жизнь Свертка по партиям редактирование DBF Армия Деньги перенос документов Обзоры сертфикаты Структура 1С СМС вирус SMS уменьшить размер базы Экстремальные игры портативный аккумулятор День жестянщика XPE jaws Мужчина и женщина Документы на почту Отношения Вопросы Интерент код защита реестр Интересные места Пошаговая свертка Программы Обработки расчет ПЗД 1с и MySQL антивирусы сбились номера документов Автомобили office 2003 Отзывы 1с реестр HP Pavilion dv6000 Методика свертки 1С вирус эмулирует нажатие Win Оптимизация Отчет Windows XP СМС оплата пакетный запуск 1С взломать пароль мошенничество узнать пароль печать от поставщика связь Установка Windows Система свертка торговли Работа удаляем пароли автозапуск сайт Удаление партий Драйвера Программы для 1С Оборудование Ошибки 1С Сайты дравер MySQL скачать программы для слепых Свертка базы 1С Взлом 1 Скачать 1С Взлом 1С Финансы Спутниковое ТВ homachi локальная сеть через интернет Вся автоматизация Загрузка с компакт - диска Zver DVD Драйвер ODBC скачать
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 085

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки