Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
27 января 2009 · Работа

Работая у дистрибьюторов одной известной марки пива организую и программирую учет этого самого пива. При этом есть несколько нюансов, отличных от организации товарооборота в других организациях.


18 января 2010 ·

Много мне пишут по теме свертка 1с, методика свертки, быстрое удаление документов в 1С, задают много вопросов, попробую ответить на основные из них. 1. Что такое свертка и зачем она нужна? Обработка свертки базы 1С представляет собой выгрузку остатков по складам, взаиморасчетов, остатков по кассе и банку, взаиморасчетов в подотчетных лиц. Далее очистка базы данных […]


Метки

Метки записей
1с реестр Программы для 1С взломать пароль Взлом Финансы свертка торговли Вопросы редактирование DBF уменьшить размер базы Взлом 1 автозапуск гаджеты Интернет вирус удаление документов сайт Юмор открыть xlsx docx Пошаговая свертка Программы свертка в картинках Обзоры Вирусы homachi локальная сеть через интернет LiveCD Dr.Web Сайты Драйвера Спорт Интересные места сверка базы 1С Oracle Asus Eee Мужчина и женщина Деньги сбились номера документов Отношения Новая форма счет-Фактуры Ошибки 1С сертфикаты Жизнь Структура 1С ZverCD удаляем пароли Драйвер ODBC скачать jaws партии Удаление партий Работа код защита Добавить новую метку СМС оплата перенос документов Оборудование Методика свертки 1С заблокирован реестр контент-провайдер свертка Drivers XPE Анализ ПДЗ Бухгалтерия автоматизация Установка Windows Командная строка HP Pavilion dv6000 Свертка базы 1С Отчет узнать пароль Спутниковое ТВ Видео Экстремальные игры бесплатно Вся восстановить нумерацию День жестянщика Интерент программы для слепых СМС Проблемы Отзывы Альпинизм Zver DVD Обработки Игры Фото Свертка по партиям Скачать 1С Оптимизация просроченная дебиторская задолженность пакетный запуск 1С скачать конвертер office 2003-2007 портативный аккумулятор расчет ПЗД мошенничество Взлом 1С вирус SMS антивирусы Подключить 1С к MySQL 1с и MySQL вирус эмулирует нажатие Win Автомобили Windows XP Кино Лирика дравер MySQL скачать перенумарация office 2003 Экономика Свертка 1С связь переустановка windows Интренет Печатные формы печать от поставщика антивирус Делаем LiveCD Загрузка с компакт - диска office 2007 Документы на почту Файлы 1С новости Армия Система
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 046

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки