Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
28 января 2012 · Железки

Dr.HD F15 — бюджетная модель относительно небольшого размера, продолжающая линейку ресиверов Dr.HD F16. Имеется  возможность обмена данными (ПО, списки каналов) через порт RS -232C и USB, как с компьютера на ресивер, так и с ресивера на компьютер, многоязычный графический интерфейс пользователя, сортировка каналов (по алфавиту, по транспондеру, либо по принципу кодированные/не кодированные), функции PVR и […]


6 февраля 2009 · Вопросы и ответы

Рассмотрим установку WordPress на локалхосте, то есть на локально установленном  Apache из комплекта денвер (как установить апач можно почитать здесь) Итак. Мы имеем установленный Вэб — сервер (Апач), работающий MySQL, допустим, что диск для размещения сайта при установке Apach мы выбрали Z:.


Метки

Метки записей
Новая форма счет-Фактуры бесплатно Интересные места СМС оплата взломать пароль Драйвер ODBC скачать Вся просроченная дебиторская задолженность Ошибки 1С Игры Жизнь Экономика Windows XP Командная строка Оборудование программы для слепых Свертка по партиям Альпинизм контент-провайдер Подключить 1С к MySQL переустановка windows Спорт office 2003 Бухгалтерия СМС вирус SMS HP Pavilion dv6000 восстановить нумерацию Программы Отношения LiveCD Dr.Web Взлом 1 Взлом 1С Свертка базы 1С вирус эмулирует нажатие Win Обработки День жестянщика расчет ПЗД новости Видео Файлы 1С перенос документов jaws партии Zver DVD Вопросы сбились номера документов Oracle Юмор сертфикаты удаление документов Финансы свертка связь homachi локальная сеть через интернет office 2007 мошенничество Проблемы Печатные формы перенумарация Документы на почту Свертка 1С Drivers Интерент гаджеты автоматизация удаляем пароли свертка в картинках Драйвера 1с реестр Добавить новую метку Вирусы Делаем LiveCD 1с и MySQL ZverCD Сайты XPE код защита Скачать 1С Экстремальные игры Удаление партий Лирика Работа Интернет Установка Windows Методика свертки 1С антивирус свертка торговли реестр Обзоры печать от поставщика скачать конвертер office 2003-2007 Мужчина и женщина уменьшить размер базы Пошаговая свертка Загрузка с компакт - диска Asus Eee портативный аккумулятор Фото Анализ ПДЗ Структура 1С открыть xlsx docx Армия Взлом сверка базы 1С пакетный запуск 1С Оптимизация Кино дравер MySQL скачать Спутниковое ТВ Интренет Автомобили антивирусы редактирование DBF Отзывы автозапуск заблокирован Система узнать пароль Отчет Деньги Программы для 1С вирус сайт
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 085

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки