Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
19 мая 2009 · Всячина

Каждому знакомо чувство, когда кажется, что он способен перевернуть мир, когда просыпаясь утром знаешь, что это будет лучший день в твоей жизни, что произойдет много ярких событий, что все будет так, как ты захочешь, и знаешь, что способен на все… В такие позитивные моменты хочется созидать много хорошего, нужного, в эти дни улыбка не сходит […]


7 октября 2009 · Всячина

Вот сделал ремонт в ванной, кафель положил, полы залил, сантехнику проложил. Решил поставить душевую кабину, ибо не любитель понежиться в ванной. Долго выбирал кабинку, бюджет был сильно урезан, поэтому круг поиска модели душевой кабина был сильно сужен. Ванная комната у меня стандартная — 150 см на 170 см, поэтому решил брать кабину 90 на 90 […]


Метки

Метки записей
удаляем пароли День жестянщика реестр Оборудование Свертка базы 1С Обзоры Удаление партий пакетный запуск 1С восстановить нумерацию Командная строка Лирика Юмор Интренет код защита Программы для 1С Сайты сайт открыть xlsx docx Отчет свертка в картинках Drivers автозапуск печать от поставщика сертфикаты Взлом 1С Zver DVD Анализ ПДЗ Игры вирус эмулирует нажатие Win скачать конвертер office 2003-2007 Бухгалтерия Методика свертки 1С Файлы 1С Asus Eee мошенничество Кино Фото homachi локальная сеть через интернет портативный аккумулятор office 2007 Альпинизм Windows XP Загрузка с компакт - диска СМС Свертка 1С свертка XPE Финансы jaws вирус редактирование DBF программы для слепых Пошаговая свертка Оптимизация контент-провайдер Подключить 1С к MySQL дравер MySQL скачать 1с и MySQL office 2003 партии Автомобили Установка Windows новости автоматизация LiveCD Dr.Web гаджеты Вся связь вирус SMS переустановка windows ZverCD удаление документов антивирус Деньги Структура 1С СМС оплата свертка торговли Экстремальные игры сбились номера документов взломать пароль Взлом 1 Мужчина и женщина Проблемы 1с реестр Обработки Спорт Скачать 1С Свертка по партиям просроченная дебиторская задолженность расчет ПЗД бесплатно Отношения Добавить новую метку Вопросы Интересные места Отзывы Делаем LiveCD Новая форма счет-Фактуры HP Pavilion dv6000 Программы Работа Ошибки 1С Система Спутниковое ТВ перенос документов антивирусы Жизнь Интернет уменьшить размер базы Интерент узнать пароль сверка базы 1С перенумарация Видео Драйвер ODBC скачать Печатные формы Oracle Документы на почту Экономика Вирусы Драйвера заблокирован Армия Взлом
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 053

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки