Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
24 января 2010 · Всячина

Друг дал погонять электронную сигарету. Интересная вещица. Представляет собой цилиндр, внешне очень похожий на обычную сигарету, но немного длиннее и тяжелее. Что такое электронная сигарета Электронная сигарета состоит из нескольких частей — самого корпуса, выполненного из пластика и фильтра, в котором содержится капсула со специальной жидкостью, которая при вдыхании проходит через нагревательный элемент (который в […]


Эти форматы — форматы нового Microsoft Office 2007. Сейчас часто возникает проблема с совместимостью версий 2003 и 2007 офиса. Некоторые уже перешли на Microsoft Office 2007, а некоторые — нет и у них нет возможности. Что делать чтобы открыть файлы с расширением DOCX и XLSX, если у вас установлен офис 2003? Для этого майкрософт сделала […]


Метки

Метки записей
Отчет гаджеты Отношения Интересные места День жестянщика вирус SMS 1с и MySQL Вся HP Pavilion dv6000 Бухгалтерия сайт Игры скачать конвертер office 2003-2007 Лирика Деньги Видео Oracle Работа Asus Eee Установка Windows Отзывы Интерент портативный аккумулятор Ошибки 1С Файлы 1С Новая форма счет-Фактуры переустановка windows дравер MySQL скачать Взлом homachi локальная сеть через интернет Кино удаление документов jaws Альпинизм Обработки Удаление партий СМС оплата Юмор office 2007 печать от поставщика СМС автоматизация Экстремальные игры программы для слепых XPE LiveCD Dr.Web Drivers Жизнь ZverCD бесплатно Оптимизация Финансы Система Экономика Свертка 1С восстановить нумерацию вирус эмулирует нажатие Win Загрузка с компакт - диска Делаем LiveCD Добавить новую метку Документы на почту связь сверка базы 1С Структура 1С Программы для 1С перенумарация Армия Печатные формы Командная строка Интренет Пошаговая свертка Подключить 1С к MySQL Обзоры Оборудование узнать пароль office 2003 расчет ПЗД контент-провайдер Свертка базы 1С свертка 1с реестр антивирусы Zver DVD Программы партии Драйвера Сайты Windows XP мошенничество Спутниковое ТВ перенос документов Спорт редактирование DBF Скачать 1С Вирусы сбились номера документов Фото Автомобили Драйвер ODBC скачать вирус открыть xlsx docx уменьшить размер базы Методика свертки 1С взломать пароль Взлом 1С пакетный запуск 1С новости автозапуск Проблемы свертка торговли свертка в картинках сертфикаты Вопросы Анализ ПДЗ Мужчина и женщина Свертка по партиям код защита Взлом 1 Интернет заблокирован реестр просроченная дебиторская задолженность удаляем пароли антивирус
3 августа 2011

Как отправить несколько файлов во вложении с помощью DialMail

Автор статьи: , 3 августа 2011 в рубрике . Метки: , , . Просмотров: 1 030

Иногда использую внешнюю компоненту DialMail для отправки почты из 1С.

Сегодня столкнулся с проблемой, что не получается вложить несколько файлов-вложений в письмо.

Пробовал перечислять имена файлов — вложений через запятую, но DialMail вообще отказывалась отправлять письма.

В интернете толкового решения не нашел, документации нет… Подсказал друг-программист.

Как оказалось чтобы отправить несколько файлов во вложении к письму необходимо имя каждого файла включать в кавычки и мена перечислять через запятую

Вот пример кода для 1С 7.7:


Кавычка = """";
Если флХЛС = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     Иначе
          ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаХЛС)+Кавычка;
     КонецЕсли;
КонецЕсли;
Если флПДФ = 1 Тогда
     Если СокрЛП(ВыбФайл) = "" Тогда
          ВыбФайл = Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     Иначе
         ВыбФайл = ВыбФайл + "," + Кавычка+СокрЛП(ИмяФайлаПДФ)+Кавычка;
     КонецЕсли;
КонецЕсли;
Почта.СоздатьПисьмо(ОбрАдр,Адрес,,Тема,,ТелоПисьма,СокрЛП(ВыбФайл));

В итоге ВыбФайл должен принимать примерно такое значение:

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru


ВыбФайл = ""C:mailschet00000001.xls","C:mailschet00000001.pdf""




Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки