Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
27 января 2010 · Всячина

Коллекционировать можно все! Причем, это занятие настолько поглощает, что заядлые коллекционеры порой тратят сумасшедшие деньги на то, чтобы приобрести в свою коллекцию вещицу, поисками которой они занимались достаточно давно. Что может выступать в роли объекта хобби? Что угодно! Чем неожиданней, тем интереснее! Чем красивее, тем лучше! Булавки, фантики, часы «ориент», монеты, картины, автомобили. Главное в […]


До недавнего времени работала конструкция, использующая WebDAV, код 1С выглядел примерно так: Приемник = «https://ЛОГИН:ПАРОЛЬ@webdav.yandex.ru/ИМЯФАЙЛА.XML»; Приемник = «c:\ИМЯФАЙЛА.XML»; КопироватьФайл(Источник, Приемник); Где, ЛОГИН — имя пользователя на Яндекс-Диске, ПАРОЛЬ — соответственно, пароль пользователя, Но недавно я обнаружил, что Яндекс диск включил SSL — шифрование и вышеприведенный код перестал работать. Для моих наработок необходим более простой способ обмена. Я пришел […]


Метки

Метки записей
автоматизация Сайты Новая форма счет-Фактуры Установка Windows Драйвера дравер MySQL скачать Делаем LiveCD Удаление партий вирус ZverCD Файлы 1С расчет ПЗД Подключить 1С к MySQL связь office 2007 Лирика LiveCD Dr.Web печать от поставщика мошенничество Видео Скачать 1С Windows XP портативный аккумулятор Вся Драйвер ODBC скачать Спорт Добавить новую метку Кино Загрузка с компакт - диска Свертка по партиям Вопросы удаляем пароли 1с и MySQL реестр заблокирован Интерент homachi локальная сеть через интернет Программы автозапуск вирус эмулирует нажатие Win Финансы восстановить нумерацию перенумарация скачать конвертер office 2003-2007 Оптимизация антивирусы Обзоры взломать пароль бесплатно вирус SMS Фото Армия свертка партии HP Pavilion dv6000 Взлом 1 Asus Eee Экстремальные игры открыть xlsx docx office 2003 Обработки просроченная дебиторская задолженность Oracle Отчет Интересные места Автомобили Вирусы Отзывы сбились номера документов антивирус Взлом 1С Свертка базы 1С Игры сверка базы 1С Взлом уменьшить размер базы Отношения Структура 1С переустановка windows Интренет Альпинизм День жестянщика Система Методика свертки 1С свертка в картинках гаджеты узнать пароль Экономика Жизнь удаление документов новости редактирование DBF Программы для 1С СМС сертфикаты Анализ ПДЗ Печатные формы Деньги пакетный запуск 1С Пошаговая свертка Zver DVD сайт Оборудование Командная строка jaws Юмор Работа Свертка 1С Drivers XPE код защита программы для слепых Спутниковое ТВ Проблемы перенос документов Бухгалтерия 1с реестр Мужчина и женщина Ошибки 1С Интернет СМС оплата контент-провайдер Документы на почту свертка торговли
13 января 2011

Ограничение прав доступа к элементам справочника 1С 7.7

Автор статьи: , 13 января 2011 в рубрике . Метки: , , . Просмотров: 6 252

Как известно стандартными средствами мы не можем указать, что пользователь не имеет права видеть конкретные элементы справочников. Например, возьмем справочник «Склады». Хотелось бы, чтобы конкретный менеджер мог видеть только свой список Складов (контрагентов, номенклатуры и т.д.), тех, с которыми он работает.

Как это реализовать Ограничение прав доступа менеджера к чужим элементам справочника

На самом деле все просто. Необходимо использовать лишь одну команду ИспользоватьСписокЭлементов.

Создаем новый справочник «Безопасность», который подчинен справочнику «Пользователи», и в котором будет хранится информация о разрешенных элементах.

safe Ограничение прав доступа к элементам справочника 1С 7.7

Справочник Безопасность

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Этот справочник будет заполняться для каждого пользователя отдельно.


Далее в глобальном модуле (можно непосредственно в модуле формы списка (подбора) написать функцию, которая будет формировать список складов / номенклатуры /контрагентов.


Функция ПолучитьСписокСкладов() Экспорт
СписокСкладов = СоздатьОбъект("СписокЗначений");
СпрСклады = СоздатьОбъект("Справочник.Склады");
СпрПользователь = СоздатьОбъект("Справочник.Пользователи");
СпрПользователь.ВыбратьЭлементы();
СпрБезопасность = СоздатьОбъект("Справочник.Безопасность");
СпрБезопасность.ИспользоватьВладельца(глПользователь);
ВыбСклады = СоздатьОбъект("Справочник.Безопасность");
ВыбСклады.ИспользоватьВладельца(глПользователь);
ВыбСклады.ВыбратьЭлементы();
ВыбСклады.НайтиПоНаименованию("Склады");
СпрБезопасность.ИспользоватьРодителя(ВыбСклады.ТекущийЭлемент());
СпрБезопасность.ВыбратьЭлементы();
Пока СпрБезопасность.ПолучитьЭлемент() = 1 Цикл
СпрСклады.ВыбратьЭлементы();
Пока СпрСклады.ПолучитьЭлемент() = 1 Цикл
Если СпрБезопасность.Наименование = СпрСклады.Наименование Тогда
СписокСкладов.ДобавитьЗначение(СпрСклады.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат(СписокСкладов);
КонецФункции

Функцию ПолучитьСписокСкладов()  можно вызывать из формы списка справочника.


ИспользоватьСписокЭлементов(ПолучитьСписокСкладов());

И в списке пользователь увидит только разрешенные для него элементы справочников.

Точно также можно организовать отбор по реквизитам в списках справочников.

sprav Ограничение прав доступа к элементам справочника 1С 7.7

Отбор в справочнике

Например, я реализовал подобную функцию пи работе с серийными номерами

moz screenshot 1 Ограничение прав доступа к элементам справочника 1С 7.7




К записи "Ограничение прав доступа к элементам справочника 1С 7.7" 8 комментариев

Сам-то пробовал?Я о том, что при таком решении «в лоб» пользователь (при включенном режиме иерархии) увидит в списке помимо «привычных» строк с элементами — ещё и непонятные строки с красными вопросительными знаками. Происходит это от элементов в спике фильтра, которые относятся к другому родителю.Поэтому в дополнение к сказанному, в общем случае:1) полный список доступных использовать в качестве фильтра следует при каждом переключении в режим отключения иерархии (накладывать фильтр с полным списком доступа);2) при каждой смене родителя (при включенном режиме иерархии) — следует переформировать список текущего фильтра из полного с исключением из него тех элементов, у которых родитель отличается от текущего — и наложить фильтр уже по такому «урезанному» списку доступных элементов.

Ответить

Получается чтобы заполнить справочник Безопасность нужными складами. Нужно чтобы у пользователя он уже были в справочнике безопасность, ну или у админа. А как быть с новыми складами. Лезть в конфигуратор и отключать функцию.

Ответить

На справочник безопасность у админа полный доступ и он назначает каждому пользователю нужные элементы.

Ответить

Так ведь фильтр для него все равно сработает. И в коде нигде не увидел контроль прав для админа.

Ответить

Я давно писал, сейчас в код не вникал, значит где то стоит отработка прав админа и отмена для него всех фильтров.
Чу3ть позже подниму MD шник посмотрю как я там делал

Ответить

Очень жду вашего ответа, мне сейчас очень важна эта тема!

Ответить

Выдает ошибку:Переменная не определена (глРользователь)

Ответить

глПользователь — это не стандартная функция, она есть в торговле, а, например, в бухгалтерии ее нет. Вы видимо пытаетесь на бухгалтерии это все реализовать?

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки