Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
25 февраля 2013 · , Анализ

Старый клиент решил еще немного доработать базу Управление Торговлей, ред 10.3. Про предыдущие доработки можно прочесть: 1. Часть первая. Перенос данных. 2. Часть вторая. Справочники. 3. Часть третья. Документы. 4. Фишки На этот раз пришла идея сделать шаг к автоматизации создания заказов своим поставщикам. Занимаясь продажей автозапчастей на отечественные автомобили имеем несколько поставщиков товаров, которым необходимо делать заявки, […]


15 августа состоялся большой праздник для всех авиастроителей. По традиции на заводе «Авиастар» проходил день открытых дверей и на территорию Авиастара пускали всех желающих. В этом году я туда не попал, номожно прочитать как проходил день открытых дверей на Авиастаре в прошлом году. Так же, по традиции проводилось авиашоу, на дороге, ведущей от завода «Авиастар» […]


Метки

Метки записей
Интренет Asus Eee Автомобили печать от поставщика Жизнь вирус SMS Windows XP связь office 2007 открыть xlsx docx удаляем пароли Оборудование Командная строка вирус эмулирует нажатие Win Обзоры Отзывы автозапуск Сайты просроченная дебиторская задолженность Пошаговая свертка расчет ПЗД перенумарация Подключить 1С к MySQL Лирика Финансы мошенничество сбились номера документов Обработки Установка Windows Проблемы Методика свертки 1С 1с и MySQL Oracle Вся Спорт Взлом 1 удаление документов Отношения Взлом 1С Армия гаджеты Печатные формы Спутниковое ТВ XPE СМС взломать пароль Взлом свертка уменьшить размер базы office 2003 скачать конвертер office 2003-2007 реестр редактирование DBF переустановка windows узнать пароль Свертка 1С заблокирован программы для слепых сайт Работа Система LiveCD Dr.Web Фото контент-провайдер Драйвера Экстремальные игры Свертка по партиям Юмор свертка торговли восстановить нумерацию Видео ZverCD Структура 1С Интересные места Анализ ПДЗ Zver DVD пакетный запуск 1С Документы на почту Альпинизм свертка в картинках Скачать 1С Игры сверка базы 1С День жестянщика Вопросы Удаление партий портативный аккумулятор Свертка базы 1С Ошибки 1С HP Pavilion dv6000 вирус партии СМС оплата Бухгалтерия Кино дравер MySQL скачать Файлы 1С бесплатно Drivers jaws 1с реестр Интернет Деньги homachi локальная сеть через интернет Загрузка с компакт - диска Отчет Вирусы новости Новая форма счет-Фактуры код защита сертфикаты Добавить новую метку Интерент Оптимизация Делаем LiveCD перенос документов Программы Экономика Мужчина и женщина Программы для 1С антивирусы автоматизация антивирус Драйвер ODBC скачать
13 января 2011

Ограничение прав доступа к элементам справочника 1С 7.7

Автор статьи: , 13 января 2011 в рубрике . Метки: , , . Просмотров: 6 306

Как известно стандартными средствами мы не можем указать, что пользователь не имеет права видеть конкретные элементы справочников. Например, возьмем справочник «Склады». Хотелось бы, чтобы конкретный менеджер мог видеть только свой список Складов (контрагентов, номенклатуры и т.д.), тех, с которыми он работает.

Как это реализовать Ограничение прав доступа менеджера к чужим элементам справочника

На самом деле все просто. Необходимо использовать лишь одну команду ИспользоватьСписокЭлементов.

Создаем новый справочник «Безопасность», который подчинен справочнику «Пользователи», и в котором будет хранится информация о разрешенных элементах.

safe Ограничение прав доступа к элементам справочника 1С 7.7

Справочник Безопасность

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Этот справочник будет заполняться для каждого пользователя отдельно.


Далее в глобальном модуле (можно непосредственно в модуле формы списка (подбора) написать функцию, которая будет формировать список складов / номенклатуры /контрагентов.


Функция ПолучитьСписокСкладов() Экспорт
СписокСкладов = СоздатьОбъект("СписокЗначений");
СпрСклады = СоздатьОбъект("Справочник.Склады");
СпрПользователь = СоздатьОбъект("Справочник.Пользователи");
СпрПользователь.ВыбратьЭлементы();
СпрБезопасность = СоздатьОбъект("Справочник.Безопасность");
СпрБезопасность.ИспользоватьВладельца(глПользователь);
ВыбСклады = СоздатьОбъект("Справочник.Безопасность");
ВыбСклады.ИспользоватьВладельца(глПользователь);
ВыбСклады.ВыбратьЭлементы();
ВыбСклады.НайтиПоНаименованию("Склады");
СпрБезопасность.ИспользоватьРодителя(ВыбСклады.ТекущийЭлемент());
СпрБезопасность.ВыбратьЭлементы();
Пока СпрБезопасность.ПолучитьЭлемент() = 1 Цикл
СпрСклады.ВыбратьЭлементы();
Пока СпрСклады.ПолучитьЭлемент() = 1 Цикл
Если СпрБезопасность.Наименование = СпрСклады.Наименование Тогда
СписокСкладов.ДобавитьЗначение(СпрСклады.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат(СписокСкладов);
КонецФункции

Функцию ПолучитьСписокСкладов()  можно вызывать из формы списка справочника.


ИспользоватьСписокЭлементов(ПолучитьСписокСкладов());

И в списке пользователь увидит только разрешенные для него элементы справочников.

Точно также можно организовать отбор по реквизитам в списках справочников.

sprav Ограничение прав доступа к элементам справочника 1С 7.7

Отбор в справочнике

Например, я реализовал подобную функцию пи работе с серийными номерами

moz screenshot 1 Ограничение прав доступа к элементам справочника 1С 7.7




К записи "Ограничение прав доступа к элементам справочника 1С 7.7" 8 комментариев

Сам-то пробовал?Я о том, что при таком решении «в лоб» пользователь (при включенном режиме иерархии) увидит в списке помимо «привычных» строк с элементами — ещё и непонятные строки с красными вопросительными знаками. Происходит это от элементов в спике фильтра, которые относятся к другому родителю.Поэтому в дополнение к сказанному, в общем случае:1) полный список доступных использовать в качестве фильтра следует при каждом переключении в режим отключения иерархии (накладывать фильтр с полным списком доступа);2) при каждой смене родителя (при включенном режиме иерархии) — следует переформировать список текущего фильтра из полного с исключением из него тех элементов, у которых родитель отличается от текущего — и наложить фильтр уже по такому «урезанному» списку доступных элементов.

Ответить

Получается чтобы заполнить справочник Безопасность нужными складами. Нужно чтобы у пользователя он уже были в справочнике безопасность, ну или у админа. А как быть с новыми складами. Лезть в конфигуратор и отключать функцию.

Ответить

На справочник безопасность у админа полный доступ и он назначает каждому пользователю нужные элементы.

Ответить

Так ведь фильтр для него все равно сработает. И в коде нигде не увидел контроль прав для админа.

Ответить

Я давно писал, сейчас в код не вникал, значит где то стоит отработка прав админа и отмена для него всех фильтров.
Чу3ть позже подниму MD шник посмотрю как я там делал

Ответить

Очень жду вашего ответа, мне сейчас очень важна эта тема!

Ответить

Выдает ошибку:Переменная не определена (глРользователь)

Ответить

глПользователь — это не стандартная функция, она есть в торговле, а, например, в бухгалтерии ее нет. Вы видимо пытаетесь на бухгалтерии это все реализовать?

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки