Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
18 марта 2013 · Всячина, Работа

Когда-то при произношении словосочетания программирование 1С меня бросало в дрожь от непонимания сущности данного вопроса. И ничего бы не поменялось в моей жизни если бы в один прекрасный момент мне в голову не пришла идея о возможности  собственного заработка. Размышляя о том, как этого можно достичь я размышлял, советовался со своими друзьями, большинство которых, в […]


Сосед покрыл гараж за 11 тысяч. Мне вроде как тоже надо, обо кровля у меня старенькая и местами крыша по весне подтекает. Ну изучив вопрос я немного прихерел от цифры в 11 тысяч за гараж 4х6. Рулон рубимаста (это типа рубероида, только слой гудрона больше и сверху покрыт мелкими камушками стоит от 420 рублей. На […]


Метки

Метки записей
вирус Альпинизм Windows XP Работа антивирус Деньги Взлом 1С Подключить 1С к MySQL гаджеты Спорт связь Командная строка Кино Интренет Документы на почту Взлом 1 свертка в картинках сбились номера документов Программы для 1С 1с реестр XPE удаляем пароли Отношения программы для слепых jaws автоматизация Установка Windows восстановить нумерацию заблокирован Бухгалтерия Отчет Удаление партий Вся ZverCD День жестянщика Обзоры Взлом Пошаговая свертка просроченная дебиторская задолженность Отзывы Методика свертки 1С бесплатно Проблемы контент-провайдер Asus Eee СМС оплата Вопросы вирус SMS Финансы Структура 1С homachi локальная сеть через интернет Загрузка с компакт - диска Автомобили Спутниковое ТВ расчет ПЗД Сайты Система Drivers свертка Юмор Экстремальные игры мошенничество Обработки Вирусы антивирусы редактирование DBF пакетный запуск 1С Экономика Ошибки 1С Oracle сверка базы 1С Файлы 1С дравер MySQL скачать Оборудование Программы Новая форма счет-Фактуры сайт свертка торговли Свертка по партиям Печатные формы скачать конвертер office 2003-2007 Свертка базы 1С автозапуск реестр Zver DVD Оптимизация Драйвера перенос документов office 2007 Интересные места портативный аккумулятор СМС LiveCD Dr.Web Интернет переустановка windows Делаем LiveCD Жизнь код защита Интерент сертфикаты узнать пароль взломать пароль Драйвер ODBC скачать Скачать 1С печать от поставщика открыть xlsx docx Фото Игры office 2003 Мужчина и женщина удаление документов вирус эмулирует нажатие Win новости Добавить новую метку 1с и MySQL Армия Анализ ПДЗ перенумарация HP Pavilion dv6000 партии Свертка 1С Лирика уменьшить размер базы Видео
13 января 2011

Ограничение прав доступа к элементам справочника 1С 7.7

Автор статьи: , 13 января 2011 в рубрике . Метки: , , . Просмотров: 6 227

Как известно стандартными средствами мы не можем указать, что пользователь не имеет права видеть конкретные элементы справочников. Например, возьмем справочник «Склады». Хотелось бы, чтобы конкретный менеджер мог видеть только свой список Складов (контрагентов, номенклатуры и т.д.), тех, с которыми он работает.

Как это реализовать Ограничение прав доступа менеджера к чужим элементам справочника

На самом деле все просто. Необходимо использовать лишь одну команду ИспользоватьСписокЭлементов.

Создаем новый справочник «Безопасность», который подчинен справочнику «Пользователи», и в котором будет хранится информация о разрешенных элементах.

safe Ограничение прав доступа к элементам справочника 1С 7.7

Справочник Безопасность

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Этот справочник будет заполняться для каждого пользователя отдельно.


Далее в глобальном модуле (можно непосредственно в модуле формы списка (подбора) написать функцию, которая будет формировать список складов / номенклатуры /контрагентов.


Функция ПолучитьСписокСкладов() Экспорт
СписокСкладов = СоздатьОбъект("СписокЗначений");
СпрСклады = СоздатьОбъект("Справочник.Склады");
СпрПользователь = СоздатьОбъект("Справочник.Пользователи");
СпрПользователь.ВыбратьЭлементы();
СпрБезопасность = СоздатьОбъект("Справочник.Безопасность");
СпрБезопасность.ИспользоватьВладельца(глПользователь);
ВыбСклады = СоздатьОбъект("Справочник.Безопасность");
ВыбСклады.ИспользоватьВладельца(глПользователь);
ВыбСклады.ВыбратьЭлементы();
ВыбСклады.НайтиПоНаименованию("Склады");
СпрБезопасность.ИспользоватьРодителя(ВыбСклады.ТекущийЭлемент());
СпрБезопасность.ВыбратьЭлементы();
Пока СпрБезопасность.ПолучитьЭлемент() = 1 Цикл
СпрСклады.ВыбратьЭлементы();
Пока СпрСклады.ПолучитьЭлемент() = 1 Цикл
Если СпрБезопасность.Наименование = СпрСклады.Наименование Тогда
СписокСкладов.ДобавитьЗначение(СпрСклады.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат(СписокСкладов);
КонецФункции

Функцию ПолучитьСписокСкладов()  можно вызывать из формы списка справочника.


ИспользоватьСписокЭлементов(ПолучитьСписокСкладов());

И в списке пользователь увидит только разрешенные для него элементы справочников.

Точно также можно организовать отбор по реквизитам в списках справочников.

sprav Ограничение прав доступа к элементам справочника 1С 7.7

Отбор в справочнике

Например, я реализовал подобную функцию пи работе с серийными номерами

moz screenshot 1 Ограничение прав доступа к элементам справочника 1С 7.7




К записи "Ограничение прав доступа к элементам справочника 1С 7.7" 8 комментариев

Сам-то пробовал?Я о том, что при таком решении «в лоб» пользователь (при включенном режиме иерархии) увидит в списке помимо «привычных» строк с элементами — ещё и непонятные строки с красными вопросительными знаками. Происходит это от элементов в спике фильтра, которые относятся к другому родителю.Поэтому в дополнение к сказанному, в общем случае:1) полный список доступных использовать в качестве фильтра следует при каждом переключении в режим отключения иерархии (накладывать фильтр с полным списком доступа);2) при каждой смене родителя (при включенном режиме иерархии) — следует переформировать список текущего фильтра из полного с исключением из него тех элементов, у которых родитель отличается от текущего — и наложить фильтр уже по такому «урезанному» списку доступных элементов.

Ответить

Получается чтобы заполнить справочник Безопасность нужными складами. Нужно чтобы у пользователя он уже были в справочнике безопасность, ну или у админа. А как быть с новыми складами. Лезть в конфигуратор и отключать функцию.

Ответить

На справочник безопасность у админа полный доступ и он назначает каждому пользователю нужные элементы.

Ответить

Так ведь фильтр для него все равно сработает. И в коде нигде не увидел контроль прав для админа.

Ответить

Я давно писал, сейчас в код не вникал, значит где то стоит отработка прав админа и отмена для него всех фильтров.
Чу3ть позже подниму MD шник посмотрю как я там делал

Ответить

Очень жду вашего ответа, мне сейчас очень важна эта тема!

Ответить

Выдает ошибку:Переменная не определена (глРользователь)

Ответить

глПользователь — это не стандартная функция, она есть в торговле, а, например, в бухгалтерии ее нет. Вы видимо пытаетесь на бухгалтерии это все реализовать?

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки