Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
19 мая 2009 · Всячина

Каждому знакомо чувство, когда кажется, что он способен перевернуть мир, когда просыпаясь утром знаешь, что это будет лучший день в твоей жизни, что произойдет много ярких событий, что все будет так, как ты захочешь, и знаешь, что способен на все… В такие позитивные моменты хочется созидать много хорошего, нужного, в эти дни улыбка не сходит […]


26 июля 2011 ·

Оптовые торговые фирмы в современном мире стремятся повышать продажи любыми способами, в том числе и ускорения процесса подачи и обработки заказов от покупателей, а покупатели в свою очередь обнаглели до такой степени что им лень оторвать задницу и придти самим за покупкой товара для своих торговых точек. Чтоб решить эту проблему придумали таких людей как […]


Метки

Метки записей
Свертка 1С Оптимизация печать от поставщика HP Pavilion dv6000 связь мошенничество Добавить новую метку Деньги Удаление партий Мужчина и женщина удаление документов День жестянщика взломать пароль вирус эмулирует нажатие Win 1с и MySQL перенумарация Взлом автозапуск перенос документов Лирика бесплатно Asus Eee Спорт Кино вирус Юмор заблокирован портативный аккумулятор Свертка по партиям Свертка базы 1С Установка Windows Взлом 1 Отношения контент-провайдер гаджеты просроченная дебиторская задолженность Интренет Оборудование Работа Отчет партии открыть xlsx docx 1с реестр Oracle редактирование DBF расчет ПЗД Армия ZverCD свертка торговли office 2007 сверка базы 1С уменьшить размер базы Скачать 1С Загрузка с компакт - диска Автомобили Экстремальные игры сбились номера документов Windows XP Анализ ПДЗ скачать конвертер office 2003-2007 Вирусы office 2003 Игры восстановить нумерацию СМС оплата Командная строка Обработки LiveCD Dr.Web код защита Сайты Фото Жизнь Файлы 1С Вопросы Zver DVD Драйвер ODBC скачать Программы пакетный запуск 1С свертка свертка в картинках Взлом 1С программы для слепых Проблемы Ошибки 1С Drivers антивирусы Интерент Структура 1С Экономика Альпинизм XPE Печатные формы Интересные места Подключить 1С к MySQL Спутниковое ТВ сертфикаты дравер MySQL скачать реестр узнать пароль Вся homachi локальная сеть через интернет Программы для 1С СМС Бухгалтерия jaws Новая форма счет-Фактуры переустановка windows Методика свертки 1С Драйвера удаляем пароли Пошаговая свертка Интернет Обзоры Видео вирус SMS Делаем LiveCD Финансы Документы на почту автоматизация Система Отзывы сайт антивирус новости
13 января 2011

Ограничение прав доступа к элементам справочника 1С 7.7

Автор статьи: , 13 января 2011 в рубрике . Метки: , , . Просмотров: 6 186

Как известно стандартными средствами мы не можем указать, что пользователь не имеет права видеть конкретные элементы справочников. Например, возьмем справочник «Склады». Хотелось бы, чтобы конкретный менеджер мог видеть только свой список Складов (контрагентов, номенклатуры и т.д.), тех, с которыми он работает.

Как это реализовать Ограничение прав доступа менеджера к чужим элементам справочника

На самом деле все просто. Необходимо использовать лишь одну команду ИспользоватьСписокЭлементов.

Создаем новый справочник «Безопасность», который подчинен справочнику «Пользователи», и в котором будет хранится информация о разрешенных элементах.

safe Ограничение прав доступа к элементам справочника 1С 7.7

Справочник Безопасность

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Этот справочник будет заполняться для каждого пользователя отдельно.


Далее в глобальном модуле (можно непосредственно в модуле формы списка (подбора) написать функцию, которая будет формировать список складов / номенклатуры /контрагентов.


Функция ПолучитьСписокСкладов() Экспорт
СписокСкладов = СоздатьОбъект("СписокЗначений");
СпрСклады = СоздатьОбъект("Справочник.Склады");
СпрПользователь = СоздатьОбъект("Справочник.Пользователи");
СпрПользователь.ВыбратьЭлементы();
СпрБезопасность = СоздатьОбъект("Справочник.Безопасность");
СпрБезопасность.ИспользоватьВладельца(глПользователь);
ВыбСклады = СоздатьОбъект("Справочник.Безопасность");
ВыбСклады.ИспользоватьВладельца(глПользователь);
ВыбСклады.ВыбратьЭлементы();
ВыбСклады.НайтиПоНаименованию("Склады");
СпрБезопасность.ИспользоватьРодителя(ВыбСклады.ТекущийЭлемент());
СпрБезопасность.ВыбратьЭлементы();
Пока СпрБезопасность.ПолучитьЭлемент() = 1 Цикл
СпрСклады.ВыбратьЭлементы();
Пока СпрСклады.ПолучитьЭлемент() = 1 Цикл
Если СпрБезопасность.Наименование = СпрСклады.Наименование Тогда
СписокСкладов.ДобавитьЗначение(СпрСклады.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат(СписокСкладов);
КонецФункции

Функцию ПолучитьСписокСкладов()  можно вызывать из формы списка справочника.


ИспользоватьСписокЭлементов(ПолучитьСписокСкладов());

И в списке пользователь увидит только разрешенные для него элементы справочников.

Точно также можно организовать отбор по реквизитам в списках справочников.

sprav Ограничение прав доступа к элементам справочника 1С 7.7

Отбор в справочнике

Например, я реализовал подобную функцию пи работе с серийными номерами

moz screenshot 1 Ограничение прав доступа к элементам справочника 1С 7.7




К записи "Ограничение прав доступа к элементам справочника 1С 7.7" 8 комментариев

Сам-то пробовал?Я о том, что при таком решении «в лоб» пользователь (при включенном режиме иерархии) увидит в списке помимо «привычных» строк с элементами — ещё и непонятные строки с красными вопросительными знаками. Происходит это от элементов в спике фильтра, которые относятся к другому родителю.Поэтому в дополнение к сказанному, в общем случае:1) полный список доступных использовать в качестве фильтра следует при каждом переключении в режим отключения иерархии (накладывать фильтр с полным списком доступа);2) при каждой смене родителя (при включенном режиме иерархии) — следует переформировать список текущего фильтра из полного с исключением из него тех элементов, у которых родитель отличается от текущего — и наложить фильтр уже по такому «урезанному» списку доступных элементов.

Ответить

Получается чтобы заполнить справочник Безопасность нужными складами. Нужно чтобы у пользователя он уже были в справочнике безопасность, ну или у админа. А как быть с новыми складами. Лезть в конфигуратор и отключать функцию.

Ответить

На справочник безопасность у админа полный доступ и он назначает каждому пользователю нужные элементы.

Ответить

Так ведь фильтр для него все равно сработает. И в коде нигде не увидел контроль прав для админа.

Ответить

Я давно писал, сейчас в код не вникал, значит где то стоит отработка прав админа и отмена для него всех фильтров.
Чу3ть позже подниму MD шник посмотрю как я там делал

Ответить

Очень жду вашего ответа, мне сейчас очень важна эта тема!

Ответить

Выдает ошибку:Переменная не определена (глРользователь)

Ответить

глПользователь — это не стандартная функция, она есть в торговле, а, например, в бухгалтерии ее нет. Вы видимо пытаетесь на бухгалтерии это все реализовать?

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки