Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.

В последнее время типы вирусов сильно видоизменились. Если раньше целью вирусов было уничтожение данных, информации, нанесение вреда компьютеру, но в наш век высоких технологий вирусы в первую очередь направлены на «зарабатывание» денег, например блокирование компьютера, с целью получения денег посредством отправки SMS сообщения на заданный номер, а для того, чтобы увеличить вероятность того, что человек […]


До недавнего времени работала конструкция, использующая WebDAV, код 1С выглядел примерно так: Приемник = «https://ЛОГИН:ПАРОЛЬ@webdav.yandex.ru/ИМЯФАЙЛА.XML»; Приемник = «c:\ИМЯФАЙЛА.XML»; КопироватьФайл(Источник, Приемник); Где, ЛОГИН — имя пользователя на Яндекс-Диске, ПАРОЛЬ — соответственно, пароль пользователя, Но недавно я обнаружил, что Яндекс диск включил SSL — шифрование и вышеприведенный код перестал работать. Для моих наработок необходим более простой способ обмена. Я пришел […]


Метки

Метки записей
Новая форма счет-Фактуры Drivers Драйвера бесплатно СМС оплата Спутниковое ТВ свертка в картинках редактирование DBF Деньги Оптимизация новости Печатные формы узнать пароль удаляем пароли Автомобили Экстремальные игры сверка базы 1С гаджеты ZverCD портативный аккумулятор Бухгалтерия сбились номера документов сайт Сайты Взлом 1 Интересные места Методика свертки 1С программы для слепых просроченная дебиторская задолженность удаление документов восстановить нумерацию Интренет Отзывы взломать пароль перенос документов Добавить новую метку Загрузка с компакт - диска Вся Фото 1с реестр Свертка базы 1С HP Pavilion dv6000 Мужчина и женщина Кино Обзоры 1с и MySQL Свертка по партиям сертфикаты Оборудование Программы для 1С Взлом 1С заблокирован Программы XPE Скачать 1С Спорт jaws свертка торговли свертка Делаем LiveCD Анализ ПДЗ Видео Проблемы вирус office 2003 Игры дравер MySQL скачать перенумарация мошенничество пакетный запуск 1С открыть xlsx docx Отношения автоматизация реестр скачать конвертер office 2003-2007 Интернет LiveCD Dr.Web Документы на почту office 2007 печать от поставщика День жестянщика уменьшить размер базы Свертка 1С Asus Eee Драйвер ODBC скачать Командная строка Альпинизм переустановка windows Юмор Установка Windows Файлы 1С код защита Windows XP Армия СМС Финансы Взлом Жизнь контент-провайдер Подключить 1С к MySQL Zver DVD Обработки Удаление партий homachi локальная сеть через интернет автозапуск Работа Экономика Вопросы вирус эмулирует нажатие Win вирус SMS Ошибки 1С Лирика Интерент расчет ПЗД Система Структура 1С Отчет Oracle антивирусы антивирус Пошаговая свертка связь Вирусы партии
28 апреля 2011

Сортировка по реквизиту справочника в 1С 7.7

Автор статьи: , 28 апреля 2011 в рубрике . Метки: , , . Просмотров: 5 261

Пишу клиенту конфигу с нуля, и так вышло, что элементы справочника необходимо сортировать по нескольким реквизитам в обоих направлениях (по возрастанию и убыванию), однако 1С не позволила сортировать по убыванию напрямую, а очень надо.

juornal Сортировка по реквизиту справочника в 1С 7.7

Сортируем по нескольким реквизитам в любом направлении

Проблему решил с помощью ИспользоватьСписокЭлементов

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

ИспользоватьСписокЭлементов(<?>);
Синтаксис:
ИспользоватьСписокЭлементов(<СписокЗначений>)
Назначение:
Реализует фильтрацию элементов справочника, используя нединамический фильтр.
Параметры:
<СписокЗначений> — необязательный параметр. Значение типа — »СписокЗначений» — должен представлять собой список элементов справочника, выбранных для просмотра. Если это значение пустое, то фильтр отключается.
Замечание:
Метод доступен только в контексте Модуля формы списка справочника и относится ко всему текущему справочнику.

То есть необходимо создать список элементов, которые будут отображаться в этом справочнике.
Фишка в том, что порядок элементов полученного списка мы можем выстраивать в нужном направлении, и этот порядок будет сохранен в форме списка.
Долго думать я не стал и просто сформировал Таблицу значений с полями, которые заполнены необходимыми реквизитами.


СпрЗаказы = СоздатьОбъект("Справочник.Заказы");
СпрЗаказы.ВыбратьЭлементы();
//Здесь можно поставить условия для формирования списка,
//можно грузить не все элементы справочника,
//а лишь те которые соответствуют какому-либо отбору
Пока СпрЗаказы.ПолучитьЭлемент() = 1 Цикл
Т.НоваяСтрока();
Т.Заказ = СпрЗаказы.ТекущийЭлемент();
Т.Менеджер = СпрЗаказы.Менеджер;
Т.Поставщик = СпрЗаказы.Поставщик;
Т.Дата = СпрЗаказы.ДатаЗаказа;
КонецЦикла;

Далее все просто — сортируем полученную таблицу как нам угодно, например так (простой вариант)


Если фДА = 1 Тогда
Т.Сортировать("+Дата");
ИначеЕсли фДЯ = 1 Тогда
Т.Сортировать("-Дата");
КонецЕсли;

И создаем на основе полученной таблицы список


Сп = СоздатьОбъект("СписокЗначений");
Т.ВыбратьСтроки();
Пока Т.ПолучитьСтроку() = 1 Цикл
Сп.ДобавитьЗначение(Т.Заказ);
КонецЦикла;

Далее используем полученный список


ИспользоватьСписокЭлементов(Сп);

Для отмены всех сортировок и отборов применяем (например вешаем на кнопку)


Процедура СнятьВсеОтборы()
УстановитьОтбор("",0);
НачДата = ПолучитьПустоеЗначение("Дата");
КонДата = ПолучитьПустоеЗначение("Дата");
ВыбМенеджер = ПолучитьПустоеЗначение("Справочник.Менеджеры");
КонецПроцедуры

Вот так я решил проблему отбора и сортировки в форме списка справочника




К записи "Сортировка по реквизиту справочника в 1С 7.7" 3 комментария

А зачем перебирать таблицу для формирования списка, если можно одной командой выгрузить столбец в список.

Ответить

Дельное замечание. Можно, и так даже правильнее и быстрее, если таблица получается большой

Ответить

Огромное спасибо за решение!Вот как его можно упростить, если нужно просто выводить элементы в обратном порядке: Зак.ОбратныйПорядок(1); Зак.ВыбратьЭлементы(); Пока Зак.ПолучитьЭлемент()=1 Цикл Сп.ДобавитьЗначение(Зак.ТекущийЭлемент()); КонецЦикла; ИспользоватьСписокЭлементов(Сп);

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки