Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.

Друг занимается установкой оборудования для спутникового телевидения, настройкой спутниковых антенн и оборудования. Меня заинтересовала эта тема и я пару раз ездил с ним на установку спутниковых антенн. Хочу рассказать как это происходит, ведь ничего сложного в этом нет.


26 июля 2011 ·

Оптовые торговые фирмы в современном мире стремятся повышать продажи любыми способами, в том числе и ускорения процесса подачи и обработки заказов от покупателей, а покупатели в свою очередь обнаглели до такой степени что им лень оторвать задницу и придти самим за покупкой товара для своих торговых точек. Чтоб решить эту проблему придумали таких людей как […]


Метки

Метки записей
Отзывы Asus Eee открыть xlsx docx сертфикаты удаление документов Печатные формы Свертка 1С гаджеты Программы для 1С Вопросы Файлы 1С узнать пароль Взлом 1 Деньги Документы на почту Методика свертки 1С Спорт скачать конвертер office 2003-2007 Кино вирус LiveCD Dr.Web СМС автозапуск перенумарация бесплатно Экстремальные игры Бухгалтерия антивирусы контент-провайдер пакетный запуск 1С Вирусы Драйвера Программы код защита Oracle заблокирован сайт антивирус реестр Игры Отчет Пошаговая свертка Windows XP Структура 1С Обработки Работа office 2003 Вся уменьшить размер базы Drivers Финансы партии взломать пароль свертка Обзоры просроченная дебиторская задолженность Добавить новую метку XPE Жизнь Сайты мошенничество HP Pavilion dv6000 Zver DVD Система Оборудование Командная строка Свертка по партиям сбились номера документов Взлом 1С office 2007 автоматизация Интерент Оптимизация Интренет новости Проблемы Загрузка с компакт - диска Экономика портативный аккумулятор Новая форма счет-Фактуры перенос документов День жестянщика Мужчина и женщина сверка базы 1С Юмор удаляем пароли Взлом восстановить нумерацию программы для слепых Делаем LiveCD jaws Установка Windows homachi локальная сеть через интернет Армия Подключить 1С к MySQL редактирование DBF Драйвер ODBC скачать свертка в картинках дравер MySQL скачать Ошибки 1С 1с и MySQL Видео вирус эмулирует нажатие Win Автомобили Свертка базы 1С Удаление партий Спутниковое ТВ ZverCD переустановка windows Альпинизм Интересные места Отношения расчет ПЗД СМС оплата печать от поставщика Анализ ПДЗ 1с реестр Лирика вирус SMS Скачать 1С связь Фото свертка торговли Интернет
28 апреля 2011

Сортировка по реквизиту справочника в 1С 7.7

Автор статьи: , 28 апреля 2011 в рубрике . Метки: , , . Просмотров: 5 167

Пишу клиенту конфигу с нуля, и так вышло, что элементы справочника необходимо сортировать по нескольким реквизитам в обоих направлениях (по возрастанию и убыванию), однако 1С не позволила сортировать по убыванию напрямую, а очень надо.

juornal Сортировка по реквизиту справочника в 1С 7.7

Сортируем по нескольким реквизитам в любом направлении

Проблему решил с помощью ИспользоватьСписокЭлементов

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

ИспользоватьСписокЭлементов(<?>);
Синтаксис:
ИспользоватьСписокЭлементов(<СписокЗначений>)
Назначение:
Реализует фильтрацию элементов справочника, используя нединамический фильтр.
Параметры:
<СписокЗначений> — необязательный параметр. Значение типа — »СписокЗначений» — должен представлять собой список элементов справочника, выбранных для просмотра. Если это значение пустое, то фильтр отключается.
Замечание:
Метод доступен только в контексте Модуля формы списка справочника и относится ко всему текущему справочнику.

То есть необходимо создать список элементов, которые будут отображаться в этом справочнике.
Фишка в том, что порядок элементов полученного списка мы можем выстраивать в нужном направлении, и этот порядок будет сохранен в форме списка.
Долго думать я не стал и просто сформировал Таблицу значений с полями, которые заполнены необходимыми реквизитами.


СпрЗаказы = СоздатьОбъект("Справочник.Заказы");
СпрЗаказы.ВыбратьЭлементы();
//Здесь можно поставить условия для формирования списка,
//можно грузить не все элементы справочника,
//а лишь те которые соответствуют какому-либо отбору
Пока СпрЗаказы.ПолучитьЭлемент() = 1 Цикл
Т.НоваяСтрока();
Т.Заказ = СпрЗаказы.ТекущийЭлемент();
Т.Менеджер = СпрЗаказы.Менеджер;
Т.Поставщик = СпрЗаказы.Поставщик;
Т.Дата = СпрЗаказы.ДатаЗаказа;
КонецЦикла;

Далее все просто — сортируем полученную таблицу как нам угодно, например так (простой вариант)


Если фДА = 1 Тогда
Т.Сортировать("+Дата");
ИначеЕсли фДЯ = 1 Тогда
Т.Сортировать("-Дата");
КонецЕсли;

И создаем на основе полученной таблицы список


Сп = СоздатьОбъект("СписокЗначений");
Т.ВыбратьСтроки();
Пока Т.ПолучитьСтроку() = 1 Цикл
Сп.ДобавитьЗначение(Т.Заказ);
КонецЦикла;

Далее используем полученный список


ИспользоватьСписокЭлементов(Сп);

Для отмены всех сортировок и отборов применяем (например вешаем на кнопку)


Процедура СнятьВсеОтборы()
УстановитьОтбор("",0);
НачДата = ПолучитьПустоеЗначение("Дата");
КонДата = ПолучитьПустоеЗначение("Дата");
ВыбМенеджер = ПолучитьПустоеЗначение("Справочник.Менеджеры");
КонецПроцедуры

Вот так я решил проблему отбора и сортировки в форме списка справочника




К записи "Сортировка по реквизиту справочника в 1С 7.7" 3 комментария

А зачем перебирать таблицу для формирования списка, если можно одной командой выгрузить столбец в список.

Ответить

Дельное замечание. Можно, и так даже правильнее и быстрее, если таблица получается большой

Ответить

Огромное спасибо за решение!Вот как его можно упростить, если нужно просто выводить элементы в обратном порядке: Зак.ОбратныйПорядок(1); Зак.ВыбратьЭлементы(); Пока Зак.ПолучитьЭлемент()=1 Цикл Сп.ДобавитьЗначение(Зак.ТекущийЭлемент()); КонецЦикла; ИспользоватьСписокЭлементов(Сп);

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки