Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.

По долгу службы приходится часто устанавливать программное обеспечение, в том числе и антивирусные программы. Как то так сложилось, что работаю только с 2 мя антивирусными программами — Касперским (http://kaspersky.ru/) и NOD32 (http://esetnod32.ru/). Если честно, то мне больше по душе NOD23. Объясню почему.


20 июня 2011 ·

В прошлой статье описал механизмы создания обработки для формирования, распечатки и отправки счетов, накладных, актов выполненных работ и счет-фактур с наложенными на них подписями и печатями контрагенту. Теперь опишу как быстро самостоятельно настроить программу для отправки счетов клиенту. 1. Установка программы Программа не вносит изменений в конфигурация и полностью построена на внешних файлах (обработках) Итак, […]


Метки

Метки записей
перенос документов Oracle Ошибки 1С Делаем LiveCD Сайты Командная строка 1с и MySQL Интересные места связь Документы на почту Экстремальные игры Отчет свертка торговли Оптимизация Обработки Альпинизм редактирование DBF печать от поставщика Лирика 1с реестр Zver DVD Видео удаление документов Система Удаление партий Оборудование узнать пароль Печатные формы Интернет Структура 1С СМС оплата гаджеты вирус эмулирует нажатие Win Отзывы Анализ ПДЗ Деньги взломать пароль Спутниковое ТВ Вся мошенничество просроченная дебиторская задолженность код защита свертка восстановить нумерацию Юмор Программы для 1С Вопросы реестр jaws сбились номера документов партии Бухгалтерия контент-провайдер новости антивирус удаляем пароли Мужчина и женщина Установка Windows дравер MySQL скачать Кино Файлы 1С Добавить новую метку Финансы Новая форма счет-Фактуры Проблемы Фото Программы Интерент XPE Отношения программы для слепых Загрузка с компакт - диска СМС вирус пакетный запуск 1С расчет ПЗД Взлом LiveCD Dr.Web сертфикаты Взлом 1С Игры Подключить 1С к MySQL автозапуск Пошаговая свертка День жестянщика Asus Eee скачать конвертер office 2003-2007 Взлом 1 Свертка по партиям Windows XP портативный аккумулятор Драйвера Свертка 1С Жизнь Экономика переустановка windows вирус SMS Обзоры сверка базы 1С бесплатно Вирусы office 2007 Армия перенумарация Свертка базы 1С HP Pavilion dv6000 Спорт свертка в картинках Интренет Скачать 1С открыть xlsx docx office 2003 ZverCD homachi локальная сеть через интернет Автомобили антивирусы Drivers Драйвер ODBC скачать заблокирован автоматизация Работа уменьшить размер базы Методика свертки 1С сайт
28 апреля 2011

Сортировка по реквизиту справочника в 1С 7.7

Автор статьи: , 28 апреля 2011 в рубрике . Метки: , , . Просмотров: 5 217

Пишу клиенту конфигу с нуля, и так вышло, что элементы справочника необходимо сортировать по нескольким реквизитам в обоих направлениях (по возрастанию и убыванию), однако 1С не позволила сортировать по убыванию напрямую, а очень надо.

juornal Сортировка по реквизиту справочника в 1С 7.7

Сортируем по нескольким реквизитам в любом направлении

Проблему решил с помощью ИспользоватьСписокЭлементов

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

ИспользоватьСписокЭлементов(<?>);
Синтаксис:
ИспользоватьСписокЭлементов(<СписокЗначений>)
Назначение:
Реализует фильтрацию элементов справочника, используя нединамический фильтр.
Параметры:
<СписокЗначений> — необязательный параметр. Значение типа — »СписокЗначений» — должен представлять собой список элементов справочника, выбранных для просмотра. Если это значение пустое, то фильтр отключается.
Замечание:
Метод доступен только в контексте Модуля формы списка справочника и относится ко всему текущему справочнику.

То есть необходимо создать список элементов, которые будут отображаться в этом справочнике.
Фишка в том, что порядок элементов полученного списка мы можем выстраивать в нужном направлении, и этот порядок будет сохранен в форме списка.
Долго думать я не стал и просто сформировал Таблицу значений с полями, которые заполнены необходимыми реквизитами.


СпрЗаказы = СоздатьОбъект("Справочник.Заказы");
СпрЗаказы.ВыбратьЭлементы();
//Здесь можно поставить условия для формирования списка,
//можно грузить не все элементы справочника,
//а лишь те которые соответствуют какому-либо отбору
Пока СпрЗаказы.ПолучитьЭлемент() = 1 Цикл
Т.НоваяСтрока();
Т.Заказ = СпрЗаказы.ТекущийЭлемент();
Т.Менеджер = СпрЗаказы.Менеджер;
Т.Поставщик = СпрЗаказы.Поставщик;
Т.Дата = СпрЗаказы.ДатаЗаказа;
КонецЦикла;

Далее все просто — сортируем полученную таблицу как нам угодно, например так (простой вариант)


Если фДА = 1 Тогда
Т.Сортировать("+Дата");
ИначеЕсли фДЯ = 1 Тогда
Т.Сортировать("-Дата");
КонецЕсли;

И создаем на основе полученной таблицы список


Сп = СоздатьОбъект("СписокЗначений");
Т.ВыбратьСтроки();
Пока Т.ПолучитьСтроку() = 1 Цикл
Сп.ДобавитьЗначение(Т.Заказ);
КонецЦикла;

Далее используем полученный список


ИспользоватьСписокЭлементов(Сп);

Для отмены всех сортировок и отборов применяем (например вешаем на кнопку)


Процедура СнятьВсеОтборы()
УстановитьОтбор("",0);
НачДата = ПолучитьПустоеЗначение("Дата");
КонДата = ПолучитьПустоеЗначение("Дата");
ВыбМенеджер = ПолучитьПустоеЗначение("Справочник.Менеджеры");
КонецПроцедуры

Вот так я решил проблему отбора и сортировки в форме списка справочника




К записи "Сортировка по реквизиту справочника в 1С 7.7" 3 комментария

А зачем перебирать таблицу для формирования списка, если можно одной командой выгрузить столбец в список.

Ответить

Дельное замечание. Можно, и так даже правильнее и быстрее, если таблица получается большой

Ответить

Огромное спасибо за решение!Вот как его можно упростить, если нужно просто выводить элементы в обратном порядке: Зак.ОбратныйПорядок(1); Зак.ВыбратьЭлементы(); Пока Зак.ПолучитьЭлемент()=1 Цикл Сп.ДобавитьЗначение(Зак.ТекущийЭлемент()); КонецЦикла; ИспользоватьСписокЭлементов(Сп);

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки