Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
28 ноября 2011 · Железки

Придя в любой магазин оргтехники, помимо традиционно задаваемых вопросов об устройстве и принципах работы лазерного принтера, каждый покупатель обязательно спросит про картридж, чтобы уточнить, какие дополнительные расходы требуются для обслуживания того или иного аппарата офисной техники. Картриджи бывают разных видов: • Оригинальный – выпускается тем же производителем, что и принтер. Он имеет самую высокую цену, […]


13 февраля 2009 · , Работа

Итак мы имеем большую базу данных в которой организация ведет учет несколько лет (а может и меньше — это зависит от объема документов). Рассмотрим, что нужно сделать чтобы уменьшить размер базы? Ну ответ видимо очевиден — надо удалить все документы за прошлые года (периоды), при этом сохранив все справочники, кроме справочника «Партии», т.к. в нем […]


Метки

Метки записей
Файлы 1С Zver DVD перенос документов Drivers Проблемы Интернет HP Pavilion dv6000 заблокирован Оборудование печать от поставщика удаляем пароли jaws гаджеты Альпинизм пакетный запуск 1С Сайты Экстремальные игры сайт Отчет Документы на почту Методика свертки 1С Мужчина и женщина сертфикаты Asus Eee партии Oracle 1с реестр homachi локальная сеть через интернет Игры Пошаговая свертка контент-провайдер XPE новости СМС оплата Вирусы Отношения Взлом 1С удаление документов Кино Свертка 1С программы для слепых Драйвера День жестянщика LiveCD Dr.Web Юмор Оптимизация Видео Работа Командная строка взломать пароль Интересные места Деньги Свертка по партиям Армия Делаем LiveCD office 2003 Интренет 1с и MySQL переустановка windows автозапуск Печатные формы Загрузка с компакт - диска Спутниковое ТВ код защита Взлом 1 Добавить новую метку Лирика Вопросы Драйвер ODBC скачать реестр просроченная дебиторская задолженность Фото вирус эмулирует нажатие Win сверка базы 1С редактирование DBF Экономика связь мошенничество Система Обзоры Бухгалтерия свертка в картинках Удаление партий сбились номера документов дравер MySQL скачать Windows XP узнать пароль Программы СМС Установка Windows восстановить нумерацию Взлом Жизнь Анализ ПДЗ вирус SMS Скачать 1С свертка портативный аккумулятор Вся скачать конвертер office 2003-2007 свертка торговли Спорт Новая форма счет-Фактуры office 2007 открыть xlsx docx расчет ПЗД перенумарация Программы для 1С Интерент Обработки антивирусы Свертка базы 1С Ошибки 1С Структура 1С ZverCD уменьшить размер базы автоматизация антивирус Подключить 1С к MySQL вирус Отзывы Автомобили бесплатно Финансы
20 апреля 2009

Быстрое удаление документов 1С

Автор статьи: , 20 апреля 2009 в рубрике , Работа. Метки: , , . Просмотров: 16 308

Иногда необходимо быстро удалить большое количество документов.

Например быстрое удаление может понадобится когда необходимо провести свертку базы данных задним числом. Например база ведется с 2005 года, а нам необходимо произвести свертку на 1 января 2009 года, чтобы все документы до 1 января 2009 года были удалены, а после 1 января 2009 года остались в базе.

В принципе удаление документов можно произвести программой в 5 строк:

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Но дело в том, что при таком удалении каждый документ будет удаляться долго, потому что в начале он быдет «распроведен», сделан не проведенным, а потом только документ будет удален. Если необходимо удалить очень много документов, то только лишь процедура удаления может занять очень продолжительное время. Как же быть в данном случае?

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Выход прост.

В DBF ной базе нам достаточно удалить файлы регистров, по которым проводятся документы. Движения по регистрам в 1С хранятся в файлах начинающихся на rg и ra. То есть это файлы rg*.* ra*.*.

Эти файлы можно удалить вручную, а можно и c помощью DOS командой каталога информационной базы. Только естественно делайте это на копии информационной базы.

del rg*.*
del ra*.*

После удаления этих файлов необходимо зайти в 1С монопольно (можно даже не переиндексировать) и запустить обработку на уделение документов.

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Если удалены файлы регистров, то обработка удаления сработает в разы быстрее, так как не придется удалять движения по регистрам.

Единственный минус этого способа — это то, что необходимо будет перепровести ВСЕ неудаленные документы.




К записи "Быстрое удаление документов 1С" 12 комментариев

Скажите, а существует ускоренные метод удаления для ИБ в sql формате? У меня тоже такой вариант, когда необходимо провести свертку базы данных 1С под SQL задним числом. Подскажите, пожалуйста!

Ответить

В SQL формате — не знаю.
На выходные удалял документы из одной ДБФ базы…
Мдя… За сутки удалялся примерно год документов.
На вторые сутки решил попробовать для сравнения.
Без удаления файлов регистров скорость удаления раза в 3-4 меньше.

Ответить

Вариант с переводом базы SQL в DBF формат не подходит, база очень громадная за 5 лет выращивания.

Ответить

Задним числом очень сложно (вернее долго) будет ее свернуть….
Если не задним числом, а скажем 1 мая, то за сутки свернется скорее всего (да и то основная часть времени уйдет на удаление партий)

Ответить

Пожалуйста, растолкуйте подробнее, что значит запустить обработку на светку базы на определенное число,допустим 01.01.09г., ее нужно писать в конфигураторе? Очень хочется свернуть базу корректно и оперативно.Спасибо заранее.

Ответить

Ответил в отдельной статье — здесь http://extremallife.ru/work/1s/qwest-svertka

Ответить

Спасибо за информацию к размышлению! 8)

Ответить

Так в 1с же есть встоенная обработка удаления документов.

Ответить

Я конечно понимаю, что предыдущее сообщение написано для рекламмы (которая удалена)…
Стандартная обработка 1С медленная…

Ответить

Вариант SQL
Я свертывал базу за три года стандартными способами сама свертка работает Отлично!!!, а вот удаление Помеченых объектов Опа Картина следующа 1200000 Объектов !!! Тупо удалять нельзя тк в базе есть Ссылки на объекты!!! пытался резать пачками вроде как получается тока долго!!

Ответить

Если тупо удалять в базе будет анархия! Лучше медленно но верно удалять!

Может у кого есть вариант написанный для SQL, выкладывайте если не жалко!

Ответить

Для SQL — это тольк остредствами SQL )))
А имена объектов (таблиц) у всех разные.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки