Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
13 марта 2009 ·

Есть несколько программ, которые очень сильно облегчают жизнь программиста. В общем то они используются не часто, но бывает, что очень сильно облегчают жизнь. Рассмотрим некоторые из этих утилит для работы с 1С. 1. 27 платформа 1с v77, не требующая взлома, кряка и пр. лабуды. Как правило применяется в личных нуждах для быстрой установки на личный […]


7 октября 2009 · Всячина

Вот сделал ремонт в ванной, кафель положил, полы залил, сантехнику проложил. Решил поставить душевую кабину, ибо не любитель понежиться в ванной. Долго выбирал кабинку, бюджет был сильно урезан, поэтому круг поиска модели душевой кабина был сильно сужен. Ванная комната у меня стандартная — 150 см на 170 см, поэтому решил брать кабину 90 на 90 […]


Метки

Метки записей
ZverCD портативный аккумулятор Проблемы заблокирован Пошаговая свертка Обработки Обзоры автозапуск свертка в картинках автоматизация вирус День жестянщика Установка Windows LiveCD Dr.Web HP Pavilion dv6000 XPE код защита Взлом 1С Скачать 1С сверка базы 1С Спорт Спутниковое ТВ Юмор реестр свертка торговли бесплатно Отношения Структура 1С Подключить 1С к MySQL мошенничество Взлом Фото СМС оплата программы для слепых Работа открыть xlsx docx Новая форма счет-Фактуры Альпинизм Интересные места Документы на почту партии просроченная дебиторская задолженность Asus Eee Oracle Драйвер ODBC скачать сбились номера документов Мужчина и женщина Драйвера Экстремальные игры Взлом 1 Оптимизация дравер MySQL скачать office 2003 печать от поставщика Печатные формы Zver DVD сайт Видео Кино Командная строка Анализ ПДЗ Windows XP 1с и MySQL Бухгалтерия Игры Вся уменьшить размер базы Лирика контент-провайдер скачать конвертер office 2003-2007 пакетный запуск 1С взломать пароль удаление документов новости удаляем пароли Интренет Система Добавить новую метку Свертка базы 1С вирус эмулирует нажатие Win Файлы 1С Деньги Вопросы Сайты расчет ПЗД Интерент переустановка windows Оборудование вирус SMS антивирусы Армия Интернет jaws Удаление партий Финансы Загрузка с компакт - диска homachi локальная сеть через интернет Экономика перенос документов узнать пароль office 2007 Жизнь СМС Автомобили Программы Отчет Отзывы 1с реестр гаджеты перенумарация Drivers Ошибки 1С свертка восстановить нумерацию связь Свертка по партиям Вирусы Делаем LiveCD сертфикаты Программы для 1С Свертка 1С Методика свертки 1С редактирование DBF антивирус
20 апреля 2009

Быстрое удаление документов 1С

Автор статьи: , 20 апреля 2009 в рубрике , Работа. Метки: , , . Просмотров: 16 522

Иногда необходимо быстро удалить большое количество документов.

Например быстрое удаление может понадобится когда необходимо провести свертку базы данных задним числом. Например база ведется с 2005 года, а нам необходимо произвести свертку на 1 января 2009 года, чтобы все документы до 1 января 2009 года были удалены, а после 1 января 2009 года остались в базе.

В принципе удаление документов можно произвести программой в 5 строк:

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Но дело в том, что при таком удалении каждый документ будет удаляться долго, потому что в начале он быдет «распроведен», сделан не проведенным, а потом только документ будет удален. Если необходимо удалить очень много документов, то только лишь процедура удаления может занять очень продолжительное время. Как же быть в данном случае?

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Выход прост.

В DBF ной базе нам достаточно удалить файлы регистров, по которым проводятся документы. Движения по регистрам в 1С хранятся в файлах начинающихся на rg и ra. То есть это файлы rg*.* ra*.*.

Эти файлы можно удалить вручную, а можно и c помощью DOS командой каталога информационной базы. Только естественно делайте это на копии информационной базы.

del rg*.*
del ra*.*

После удаления этих файлов необходимо зайти в 1С монопольно (можно даже не переиндексировать) и запустить обработку на уделение документов.

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Если удалены файлы регистров, то обработка удаления сработает в разы быстрее, так как не придется удалять движения по регистрам.

Единственный минус этого способа — это то, что необходимо будет перепровести ВСЕ неудаленные документы.




К записи "Быстрое удаление документов 1С" 12 комментариев

Скажите, а существует ускоренные метод удаления для ИБ в sql формате? У меня тоже такой вариант, когда необходимо провести свертку базы данных 1С под SQL задним числом. Подскажите, пожалуйста!

Ответить

В SQL формате — не знаю.
На выходные удалял документы из одной ДБФ базы…
Мдя… За сутки удалялся примерно год документов.
На вторые сутки решил попробовать для сравнения.
Без удаления файлов регистров скорость удаления раза в 3-4 меньше.

Ответить

Вариант с переводом базы SQL в DBF формат не подходит, база очень громадная за 5 лет выращивания.

Ответить

Задним числом очень сложно (вернее долго) будет ее свернуть….
Если не задним числом, а скажем 1 мая, то за сутки свернется скорее всего (да и то основная часть времени уйдет на удаление партий)

Ответить

Пожалуйста, растолкуйте подробнее, что значит запустить обработку на светку базы на определенное число,допустим 01.01.09г., ее нужно писать в конфигураторе? Очень хочется свернуть базу корректно и оперативно.Спасибо заранее.

Ответить

Ответил в отдельной статье — здесь http://extremallife.ru/work/1s/qwest-svertka

Ответить

Спасибо за информацию к размышлению! 8)

Ответить

Так в 1с же есть встоенная обработка удаления документов.

Ответить

Я конечно понимаю, что предыдущее сообщение написано для рекламмы (которая удалена)…
Стандартная обработка 1С медленная…

Ответить

Вариант SQL
Я свертывал базу за три года стандартными способами сама свертка работает Отлично!!!, а вот удаление Помеченых объектов Опа Картина следующа 1200000 Объектов !!! Тупо удалять нельзя тк в базе есть Ссылки на объекты!!! пытался резать пачками вроде как получается тока долго!!

Ответить

Если тупо удалять в базе будет анархия! Лучше медленно но верно удалять!

Может у кого есть вариант написанный для SQL, выкладывайте если не жалко!

Ответить

Для SQL — это тольк остредствами SQL )))
А имена объектов (таблиц) у всех разные.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки