Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
24 января 2010 · Всячина

Друг дал погонять электронную сигарету. Интересная вещица. Представляет собой цилиндр, внешне очень похожий на обычную сигарету, но немного длиннее и тяжелее. Что такое электронная сигарета Электронная сигарета состоит из нескольких частей — самого корпуса, выполненного из пластика и фильтра, в котором содержится капсула со специальной жидкостью, которая при вдыхании проходит через нагревательный элемент (который в […]


9 ноября 2010 ·

В свете последних новостей, когда фирма 1С заявила, что конфигурация Бухгалтерия предприятия редакция 1.6 с Нового, 2011 года не будет поддерживаться и все пользователи должны будут конвертировать свои базы в редакцию 2.0 решил написать пошаговую инструкцию как провести конвертацию баз БП ред. 1.6 на редакцию 2.0. Мы имеем: 1. Платформа 1С: Предприятие 8.1 2. Конфигурация […]


Метки

Метки записей
office 2007 Интренет партии переустановка windows Взлом 1С Спорт Добавить новую метку пакетный запуск 1С скачать конвертер office 2003-2007 мошенничество XPE Проблемы гаджеты вирус бесплатно автозапуск Командная строка Новая форма счет-Фактуры Интересные места портативный аккумулятор просроченная дебиторская задолженность Методика свертки 1С Бухгалтерия homachi локальная сеть через интернет Работа сверка базы 1С Файлы 1С Свертка базы 1С Сайты Обзоры сертфикаты Вирусы свертка в картинках Игры Asus Eee Армия реестр Интернет Вся редактирование DBF заблокирован СМС оплата ZverCD Видео Ошибки 1С Взлом Система Мужчина и женщина перенумарация Альпинизм Документы на почту Деньги антивирусы LiveCD Dr.Web Отчет расчет ПЗД jaws Спутниковое ТВ Фото Отзывы Drivers Программы для 1С свертка Экстремальные игры Юмор Скачать 1С Zver DVD вирус SMS Финансы Автомобили Печатные формы свертка торговли 1с и MySQL сайт антивирус Делаем LiveCD открыть xlsx docx HP Pavilion dv6000 Взлом 1 Кино Программы Анализ ПДЗ Лирика связь автоматизация узнать пароль взломать пароль Свертка по партиям Удаление партий Интерент office 2003 сбились номера документов контент-провайдер новости Свертка 1С День жестянщика программы для слепых удаление документов вирус эмулирует нажатие Win печать от поставщика Структура 1С Windows XP Установка Windows Загрузка с компакт - диска уменьшить размер базы восстановить нумерацию код защита Оборудование 1с реестр перенос документов удаляем пароли Драйвер ODBC скачать Пошаговая свертка СМС Обработки Жизнь Драйвера дравер MySQL скачать Отношения Oracle Вопросы Оптимизация Подключить 1С к MySQL Экономика
20 апреля 2009

Быстрое удаление документов 1С

Автор статьи: , 20 апреля 2009 в рубрике , Работа. Метки: , , . Просмотров: 16 452

Иногда необходимо быстро удалить большое количество документов.

Например быстрое удаление может понадобится когда необходимо провести свертку базы данных задним числом. Например база ведется с 2005 года, а нам необходимо произвести свертку на 1 января 2009 года, чтобы все документы до 1 января 2009 года были удалены, а после 1 января 2009 года остались в базе.

В принципе удаление документов можно произвести программой в 5 строк:

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Но дело в том, что при таком удалении каждый документ будет удаляться долго, потому что в начале он быдет «распроведен», сделан не проведенным, а потом только документ будет удален. Если необходимо удалить очень много документов, то только лишь процедура удаления может занять очень продолжительное время. Как же быть в данном случае?

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Выход прост.

В DBF ной базе нам достаточно удалить файлы регистров, по которым проводятся документы. Движения по регистрам в 1С хранятся в файлах начинающихся на rg и ra. То есть это файлы rg*.* ra*.*.

Эти файлы можно удалить вручную, а можно и c помощью DOS командой каталога информационной базы. Только естественно делайте это на копии информационной базы.

del rg*.*
del ra*.*

После удаления этих файлов необходимо зайти в 1С монопольно (можно даже не переиндексировать) и запустить обработку на уделение документов.

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Если удалены файлы регистров, то обработка удаления сработает в разы быстрее, так как не придется удалять движения по регистрам.

Единственный минус этого способа — это то, что необходимо будет перепровести ВСЕ неудаленные документы.




К записи "Быстрое удаление документов 1С" 12 комментариев

Скажите, а существует ускоренные метод удаления для ИБ в sql формате? У меня тоже такой вариант, когда необходимо провести свертку базы данных 1С под SQL задним числом. Подскажите, пожалуйста!

Ответить

В SQL формате — не знаю.
На выходные удалял документы из одной ДБФ базы…
Мдя… За сутки удалялся примерно год документов.
На вторые сутки решил попробовать для сравнения.
Без удаления файлов регистров скорость удаления раза в 3-4 меньше.

Ответить

Вариант с переводом базы SQL в DBF формат не подходит, база очень громадная за 5 лет выращивания.

Ответить

Задним числом очень сложно (вернее долго) будет ее свернуть….
Если не задним числом, а скажем 1 мая, то за сутки свернется скорее всего (да и то основная часть времени уйдет на удаление партий)

Ответить

Пожалуйста, растолкуйте подробнее, что значит запустить обработку на светку базы на определенное число,допустим 01.01.09г., ее нужно писать в конфигураторе? Очень хочется свернуть базу корректно и оперативно.Спасибо заранее.

Ответить

Ответил в отдельной статье — здесь http://extremallife.ru/work/1s/qwest-svertka

Ответить

Спасибо за информацию к размышлению! 8)

Ответить

Так в 1с же есть встоенная обработка удаления документов.

Ответить

Я конечно понимаю, что предыдущее сообщение написано для рекламмы (которая удалена)…
Стандартная обработка 1С медленная…

Ответить

Вариант SQL
Я свертывал базу за три года стандартными способами сама свертка работает Отлично!!!, а вот удаление Помеченых объектов Опа Картина следующа 1200000 Объектов !!! Тупо удалять нельзя тк в базе есть Ссылки на объекты!!! пытался резать пачками вроде как получается тока долго!!

Ответить

Если тупо удалять в базе будет анархия! Лучше медленно но верно удалять!

Может у кого есть вариант написанный для SQL, выкладывайте если не жалко!

Ответить

Для SQL — это тольк остредствами SQL )))
А имена объектов (таблиц) у всех разные.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки