Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
23 июля 2009 ·

Конфигурация предназначена для учета ГСМ в организации. Позволяет контролировать расход горюче-смазочных материалов на каждый автомобиль, рассчитывать расход денег на топливо, исходя из забиваемых норм расхода.


13 марта 2009 · Кино

Я обычно про фильмы не пишу, но просмотрев этот фильм решился отписать. Услышав рекламу по радио, что мол, просмотри фильма меняет мировоззрение взял под руку лубимую девушку и потащил ее в кинотеатр.


Метки

Метки записей
Обработки скачать конвертер office 2003-2007 Оптимизация бесплатно новости Альпинизм office 2007 Лирика Оборудование восстановить нумерацию Подключить 1С к MySQL Автомобили мошенничество реестр свертка в картинках сверка базы 1С Кино заблокирован антивирус партии Интересные места LiveCD Dr.Web Отзывы антивирусы Свертка базы 1С Ошибки 1С свертка торговли перенос документов контент-провайдер Драйвер ODBC скачать Документы на почту Добавить новую метку Интернет Вся Интерент Финансы Drivers код защита перенумарация XPE дравер MySQL скачать автозапуск вирус эмулирует нажатие Win Анализ ПДЗ Игры Отчет сертфикаты СМС оплата уменьшить размер базы гаджеты Делаем LiveCD Спутниковое ТВ Удаление партий Установка Windows Экономика Скачать 1С Обзоры программы для слепых 1с и MySQL Программы Oracle Вопросы портативный аккумулятор Zver DVD Новая форма счет-Фактуры Проблемы Армия Сайты Загрузка с компакт - диска удаляем пароли сбились номера документов Спорт переустановка windows вирус SMS связь узнать пароль расчет ПЗД сайт Работа 1с реестр Драйвера Экстремальные игры Файлы 1С Структура 1С Вирусы Asus Eee взломать пароль Мужчина и женщина День жестянщика удаление документов Взлом 1 Бухгалтерия вирус Программы для 1С Пошаговая свертка Методика свертки 1С Взлом 1С Интренет Взлом homachi локальная сеть через интернет office 2003 просроченная дебиторская задолженность Windows XP Свертка по партиям Юмор Система СМС Свертка 1С автоматизация Видео редактирование DBF Деньги открыть xlsx docx Жизнь Командная строка Печатные формы Фото свертка пакетный запуск 1С печать от поставщика ZverCD Отношения HP Pavilion dv6000 jaws
20 апреля 2009

Быстрое удаление документов 1С

Автор статьи: , 20 апреля 2009 в рубрике , Работа. Метки: , , . Просмотров: 16 109

Иногда необходимо быстро удалить большое количество документов.

Например быстрое удаление может понадобится когда необходимо провести свертку базы данных задним числом. Например база ведется с 2005 года, а нам необходимо произвести свертку на 1 января 2009 года, чтобы все документы до 1 января 2009 года были удалены, а после 1 января 2009 года остались в базе.

В принципе удаление документов можно произвести программой в 5 строк:

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Но дело в том, что при таком удалении каждый документ будет удаляться долго, потому что в начале он быдет «распроведен», сделан не проведенным, а потом только документ будет удален. Если необходимо удалить очень много документов, то только лишь процедура удаления может занять очень продолжительное время. Как же быть в данном случае?

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Выход прост.

В DBF ной базе нам достаточно удалить файлы регистров, по которым проводятся документы. Движения по регистрам в 1С хранятся в файлах начинающихся на rg и ra. То есть это файлы rg*.* ra*.*.

Эти файлы можно удалить вручную, а можно и c помощью DOS командой каталога информационной базы. Только естественно делайте это на копии информационной базы.

del rg*.*
del ra*.*

После удаления этих файлов необходимо зайти в 1С монопольно (можно даже не переиндексировать) и запустить обработку на уделение документов.

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Если удалены файлы регистров, то обработка удаления сработает в разы быстрее, так как не придется удалять движения по регистрам.

Единственный минус этого способа — это то, что необходимо будет перепровести ВСЕ неудаленные документы.




К записи "Быстрое удаление документов 1С" 12 комментариев

Скажите, а существует ускоренные метод удаления для ИБ в sql формате? У меня тоже такой вариант, когда необходимо провести свертку базы данных 1С под SQL задним числом. Подскажите, пожалуйста!

Ответить

В SQL формате — не знаю.
На выходные удалял документы из одной ДБФ базы…
Мдя… За сутки удалялся примерно год документов.
На вторые сутки решил попробовать для сравнения.
Без удаления файлов регистров скорость удаления раза в 3-4 меньше.

Ответить

Вариант с переводом базы SQL в DBF формат не подходит, база очень громадная за 5 лет выращивания.

Ответить

Задним числом очень сложно (вернее долго) будет ее свернуть….
Если не задним числом, а скажем 1 мая, то за сутки свернется скорее всего (да и то основная часть времени уйдет на удаление партий)

Ответить

Пожалуйста, растолкуйте подробнее, что значит запустить обработку на светку базы на определенное число,допустим 01.01.09г., ее нужно писать в конфигураторе? Очень хочется свернуть базу корректно и оперативно.Спасибо заранее.

Ответить

Ответил в отдельной статье — здесь http://extremallife.ru/work/1s/qwest-svertka

Ответить

Спасибо за информацию к размышлению! 8)

Ответить

Так в 1с же есть встоенная обработка удаления документов.

Ответить

Я конечно понимаю, что предыдущее сообщение написано для рекламмы (которая удалена)…
Стандартная обработка 1С медленная…

Ответить

Вариант SQL
Я свертывал базу за три года стандартными способами сама свертка работает Отлично!!!, а вот удаление Помеченых объектов Опа Картина следующа 1200000 Объектов !!! Тупо удалять нельзя тк в базе есть Ссылки на объекты!!! пытался резать пачками вроде как получается тока долго!!

Ответить

Если тупо удалять в базе будет анархия! Лучше медленно но верно удалять!

Может у кого есть вариант написанный для SQL, выкладывайте если не жалко!

Ответить

Для SQL — это тольк остредствами SQL )))
А имена объектов (таблиц) у всех разные.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки