Последнее обновление: 23 мая 2015 в 14:58
Подпишись на RSS
rss Подпишитесь на RSS, чтобы всегда быть в курсе событий.
7 мая 2009 · Всячина

Вчера, 6 мая, те, кто пытался уехать вечером из ценра города Ульяновска за Волгу  наблюдал занятнейшее зрелище — очередной проблеск заботы о горожанах. В час-пик перекрыли центральную улицу для подготовке к параду, посвященному празднованию годовщины Победы во 2й Мировой Войне. Понятное дело, что парад и годовщина — это дело святое и нужное, но почему нельзя […]


7 сентября 2010 · Игрушки

Покер в нашей стране, как все мы помним, недавно объявили вне закона. Но любители этой игры не унывают – ведь суровое постановление стало мощным толчком для развития покера виртуального! Играть в него официально не разрешили, но пока и не запретили, так что российские покеристы могут играть сразу за несколькими виртуальными столами сутки напролет.


Метки

Метки записей
Отчет Отношения Бухгалтерия Отзывы office 2007 Пошаговая свертка Свертка базы 1С удаление документов Спутниковое ТВ портативный аккумулятор Asus Eee ZverCD Интернет вирус эмулирует нажатие Win Вопросы Лирика Жизнь мошенничество открыть xlsx docx 1с реестр Zver DVD Программы Фото узнать пароль Вирусы Проблемы Анализ ПДЗ Оборудование Свертка по партиям вирус Добавить новую метку антивирусы Свертка 1С вирус SMS HP Pavilion dv6000 Файлы 1С Мужчина и женщина расчет ПЗД Windows XP homachi локальная сеть через интернет партии новости Видео уменьшить размер базы печать от поставщика Скачать 1С Экстремальные игры Взлом Взлом 1 Оптимизация Работа перенумарация Структура 1С jaws свертка торговли удаляем пароли Документы на почту сайт Вся Интренет взломать пароль заблокирован перенос документов СМС оплата автоматизация Подключить 1С к MySQL программы для слепых просроченная дебиторская задолженность Обработки День жестянщика СМС Интересные места Программы для 1С Армия Ошибки 1С сбились номера документов Печатные формы Новая форма счет-Фактуры Взлом 1С Установка Windows Альпинизм свертка в картинках Финансы восстановить нумерацию Загрузка с компакт - диска сертфикаты Экономика дравер MySQL скачать антивирус переустановка windows Спорт скачать конвертер office 2003-2007 office 2003 XPE Система редактирование DBF Обзоры Методика свертки 1С реестр Кино сверка базы 1С автозапуск Юмор 1с и MySQL LiveCD Dr.Web Деньги Oracle код защита Драйвер ODBC скачать свертка Командная строка контент-провайдер Drivers Интерент Сайты Делаем LiveCD гаджеты пакетный запуск 1С Драйвера бесплатно Игры Автомобили Удаление партий связь
20 апреля 2009

Быстрое удаление документов 1С

Автор статьи: , 20 апреля 2009 в рубрике , Работа. Метки: , , . Просмотров: 15 982

Иногда необходимо быстро удалить большое количество документов.

Например быстрое удаление может понадобится когда необходимо провести свертку базы данных задним числом. Например база ведется с 2005 года, а нам необходимо произвести свертку на 1 января 2009 года, чтобы все документы до 1 января 2009 года были удалены, а после 1 января 2009 года остались в базе.

В принципе удаление документов можно произвести программой в 5 строк:

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Но дело в том, что при таком удалении каждый документ будет удаляться долго, потому что в начале он быдет «распроведен», сделан не проведенным, а потом только документ будет удален. Если необходимо удалить очень много документов, то только лишь процедура удаления может занять очень продолжительное время. Как же быть в данном случае?

Авторские права на предоставленный материал принадлежат автору сайта http://extremallife.ru

Выход прост.

В DBF ной базе нам достаточно удалить файлы регистров, по которым проводятся документы. Движения по регистрам в 1С хранятся в файлах начинающихся на rg и ra. То есть это файлы rg*.* ra*.*.

Эти файлы можно удалить вручную, а можно и c помощью DOS командой каталога информационной базы. Только естественно делайте это на копии информационной базы.

del rg*.*
del ra*.*

После удаления этих файлов необходимо зайти в 1С монопольно (можно даже не переиндексировать) и запустить обработку на уделение документов.

Процедура Сформировать()
Д = СоздатьОбъект(«Документ»);
Д.ВыбратьДокументы(НачДата,КонДата);
Пока Д.ПолучитьДокумент() = 1 Цикл
Сообщить(Д.ТекущийДокумент());
Состояние(Д.ДатаДок);
Д.Удалить();
КонецЦикла;
КонецПроцедуры

Если удалены файлы регистров, то обработка удаления сработает в разы быстрее, так как не придется удалять движения по регистрам.

Единственный минус этого способа — это то, что необходимо будет перепровести ВСЕ неудаленные документы.




К записи "Быстрое удаление документов 1С" 12 комментариев

Скажите, а существует ускоренные метод удаления для ИБ в sql формате? У меня тоже такой вариант, когда необходимо провести свертку базы данных 1С под SQL задним числом. Подскажите, пожалуйста!

Ответить

В SQL формате — не знаю.
На выходные удалял документы из одной ДБФ базы…
Мдя… За сутки удалялся примерно год документов.
На вторые сутки решил попробовать для сравнения.
Без удаления файлов регистров скорость удаления раза в 3-4 меньше.

Ответить

Вариант с переводом базы SQL в DBF формат не подходит, база очень громадная за 5 лет выращивания.

Ответить

Задним числом очень сложно (вернее долго) будет ее свернуть….
Если не задним числом, а скажем 1 мая, то за сутки свернется скорее всего (да и то основная часть времени уйдет на удаление партий)

Ответить

Пожалуйста, растолкуйте подробнее, что значит запустить обработку на светку базы на определенное число,допустим 01.01.09г., ее нужно писать в конфигураторе? Очень хочется свернуть базу корректно и оперативно.Спасибо заранее.

Ответить

Ответил в отдельной статье — здесь http://extremallife.ru/work/1s/qwest-svertka

Ответить

Спасибо за информацию к размышлению! 8)

Ответить

Так в 1с же есть встоенная обработка удаления документов.

Ответить

Я конечно понимаю, что предыдущее сообщение написано для рекламмы (которая удалена)…
Стандартная обработка 1С медленная…

Ответить

Вариант SQL
Я свертывал базу за три года стандартными способами сама свертка работает Отлично!!!, а вот удаление Помеченых объектов Опа Картина следующа 1200000 Объектов !!! Тупо удалять нельзя тк в базе есть Ссылки на объекты!!! пытался резать пачками вроде как получается тока долго!!

Ответить

Если тупо удалять в базе будет анархия! Лучше медленно но верно удалять!

Может у кого есть вариант написанный для SQL, выкладывайте если не жалко!

Ответить

Для SQL — это тольк остредствами SQL )))
А имена объектов (таблиц) у всех разные.

Ответить


Оставить комментарий

*

Блог программиста 1С. Программирование 1С
Если Вас что-то заинтересовало или возникли вопросы, пишите.
petr@evseev.ru
Skype - evseev_petr
ICQ - 262808698

Сохраните меня в социальных сервисах

Комментарии

Присоединяйтесь к обсуждению
  • Леха: Мало того, что это говно-антивирус требует .Net Framework не ниже 4.0, так он еще пожирает ресурсы компьютера,...
  • tommy: AVG равно еще хуже Касперского . Иди в жопу с ним
  • просто_чайник: Не люблю этот антивирус. Заметил такую особенность. Если обновить базы в начале работы, довольно часто...
  • Елена: Самое главное. Файл для совместной работы открыть нельзя! Если надо что-то отредактировать — только...
  • Виктор: Поставили мне на работе эту замечательную программку. Работать невозможно, ужасные тормоза. Стали...

Избранное видео

Ссылки